Bug 185969 - [69cat] UI lockup after starting IDE?
[69cat] UI lockup after starting IDE?
Status: RESOLVED DUPLICATE of bug 185900
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
PC Linux
: P2 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 06:18 UTC by kawazu428
Modified: 2011-01-31 21:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump with UI locked (22.62 KB, text/plain)
2010-05-12 06:19 UTC, kawazu428
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kawazu428 2010-05-12 06:18:41 UTC
[ BUILD # : 201005112200 ]
[ JDK VERSION : 1.6.* ]

Reproduced it twice with the current build, a set (<10) of maven2 projects
opened, while editing a pom.xml file: UI completely freezes, doesn't return
(had to kill the application manually). Log output seems suspicious, about to
attach thread dump too:


INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion.FileStatusCache]:
FileStatusCache.refreshTask: Scanning in progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Subversion.cleanupTask: Scanning in
progress, trying again in 5000ms
INFO [org.netbeans.modules.subversion]: Finished indexing svn cache with 5784
entries. Elapsed time: 2940 ms.
^\2010-05-12 08:15:29
Comment 1 kawazu428 2010-05-12 06:19:19 UTC
Created attachment 98811 [details]
thread dump with UI locked
Comment 2 Petr Jiricka 2011-01-24 16:12:38 UTC
javaee does not seem to be doing anything bad - is this Maven-related?
Comment 3 Jesse Glick 2011-01-24 16:41:22 UTC
I think the problem is in masterfs, though the use of Mutex.Privileged makes it harder to see from a thread dump who might be holding the masterfs mutex.
Comment 4 Jaroslav Tulach 2011-01-31 21:34:59 UTC

*** This bug has been marked as a duplicate of bug 185900 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo