Bug 185962 - IndexOutOfBoundsException: Index: 3, Size: 3
IndexOutOfBoundsException: Index: 3, Size: 3
Status: RESOLVED DUPLICATE of bug 180960
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@platform
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 23:32 UTC by petkle
Modified: 2010-10-07 09:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.60 KB, text/plain)
2010-05-11 23:32 UTC, petkle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description petkle 2010-05-11 23:32:30 UTC
Build: NetBeans IDE Dev (Build 201005060200)
VM: OpenJDK 64-Bit Server VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_18-b18
OS: Linux

User Comments:
GUEST: simple cut and paste action!!!!!

petkle: editing xml file

GUEST: saving edited file

GUEST: closing exception reporter pane :)

GUEST: pressing enter before line beginning with #




Stacktrace: 
java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
   at java.util.ArrayList.RangeCheck(ArrayList.java:571)
   at java.util.ArrayList.get(ArrayList.java:349)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.fireContentsChanged(DefaultTabDataModel.java:454)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.setText(DefaultTabDataModel.java:159)
   at org.netbeans.swing.tabcontrol.TabbedContainer.setTitleAt(TabbedContainer.java:701)
   at org.netbeans.core.windows.view.ui.TabbedHandler.topComponentNameChanged(TabbedHandler.java:236)
Comment 1 petkle 2010-05-11 23:32:34 UTC
Created attachment 98807 [details]
stacktrace
Comment 2 Martin Entlicher 2010-05-12 14:39:30 UTC
It's updating the name of a TopComponent. I do not think this has anything to do with Outline...
Comment 3 Exceptions Reporter 2010-05-26 01:02:33 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=165639
Comment 4 Stanislav Aubrecht 2010-10-07 09:07:31 UTC

*** This bug has been marked as a duplicate of bug 180960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo