Bug 185848 - [69cat] org.openide.util.RequestProcessor$SlowItem: task failed due to: java.lang.NullPointerException
[69cat] org.openide.util.RequestProcessor$SlowItem: task failed due to: java....
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
All All
: P3 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 15:08 UTC by alied
Modified: 2012-10-30 11:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.27 KB, text/plain)
2010-05-10 15:08 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2010-05-10 15:08:11 UTC
Build: NetBeans IDE Dev (Build 201005060200)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows Vista

User Comments:
alied: debugging. Probably due to the cursor stood too much time still over a variable on the source file.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.editor.PopupManager.computeBounds(PopupManager.java:373)
   at org.netbeans.editor.PopupManager.computeBounds(PopupManager.java:288)
   at org.netbeans.editor.PopupManager.install(PopupManager.java:188)
   at org.netbeans.editor.ext.ToolTipSupport.ensureVisibility(ToolTipSupport.java:681)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:287)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:263)
Comment 1 alied 2010-05-10 15:08:14 UTC
Created attachment 98723 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2010-05-11 11:05:55 UTC
It looks like a race condition in PopupManager.
Comment 3 Miloslav Metelka 2012-10-30 11:43:21 UTC
Cannot reproduce in recent daily builds. If the problem reappears please reopen.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo