Bug 18583 - When IDE uses windows PLAF, the form editor will not open for new or existing swing components
When IDE uses windows PLAF, the form editor will not open for new or existing...
Status: CLOSED DUPLICATE of bug 18077
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows 3.1/NT
: P1 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-12 22:40 UTC by Lee Doty
Modified: 2003-06-30 18:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Doty 2001-12-12 22:40:33 UTC
Using NB 3.3 release 

When the IDE is set to use the windows PLAF, the form editor doesn't work.
When I set the IDE to use the (default) metal PLAF, the form editor works fine.

Note: when I say "PLAF", I'm talking about the pluggable look and feel of the 
IDE, not the application being developed.

There is no exception to copy, but the dialog box that pops up talks about not 
being able to find a superclass for the object.  

I get this dialog whenever I either try to add a swing component, or edit an 
already existing swing component... not sure what happens with AWT components.
Comment 1 Marian Mirilovic 2001-12-13 08:32:55 UTC
Hi 

As you can read in README :
http://www.netbeans.org/articles/releases/3.3/README.html#KnownProblems

this is known problem and it will be fixed in release 3.3.1
(January'02)

Thanx for report.


*** This issue has been marked as a duplicate of 18077 ***
Comment 2 Quality Engineering 2003-06-30 18:21:18 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 3 Quality Engineering 2003-06-30 18:29:36 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo