Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 185484 - org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher$FileLockRemainedException: Lock file still present! C:\DOCUME~1\aglybin\LOCALS~1\Temp\customProfileDirf072f40108cd4d5ea47e70a256cdd472
org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher$FileLockRem...
Status: CLOSED FIXED
Product: utilities
Classification: Unclassified
Component: Selenium
6.x
All All
: P3 with 2 votes (vote)
: 6.x
Assigned To: Martin Fousek
issues@contrib
EXCEPTIONS_REPORT
:
: 187338 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 08:41 UTC by aaaandruha
Modified: 2014-12-09 09:32 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.30 KB, text/plain)
2010-05-05 08:41 UTC, aaaandruha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aaaandruha 2010-05-05 08:41:22 UTC
Build: NetBeans IDE 6.9 Beta (Build 201004200117)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows XP

User Comments:
marsaud: Windows 2000 5.00.2195 Service Pack 4
Netbeans6.9M1 with PHP Plugin
PHPUnit 3.4.6 and Selenium module for PHP 1.0
Firefox 3.6.2

After installing Selenium Module for PHP, I am trying to "Run Selenium Tests" after adding a new "Selenium Test Case for PHP", and tests fails with the following output :

PHPUnit_Framework_Exception: Response from Selenium RC server for getNewBrowserSession(*firefox3, http://localhost/).
Failed to start new browser session: Unable to delete file C:\DOCUME~1\marsaud\LOCALS~1\Temp\customProfileDirc8682480853348aabe3780049904695d\parent.lock.

After this, all files in the custumProfileDir* mentionned above are impossible to delete because of sharing violation.

GUEST: Cancelled selenium test from the lower right hand corner (the blue progress bar) because I ran it before I created anything of value.

aaaandruha: ? ????????? ?????? Selenium for PHP ? ???????? "Run Selenium test"

marsaud: Product Version: NetBeans IDE Dev (Build 201003150200)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1252; fr_FR (nb)
Userdir: C:\Documents and Settings\Fab.FAB-AAFA1A93150\.netbeans\dev

Trying to run a PHPUnit Selenium Test Cases exported in PHP from Selenium IDE

GUEST: testing selenium test files
>Log Session: Saturday, March 13, 2010 1:45:49 PM CET
>System Info: 
  Product Version         = NetBeans IDE Dev (Build 201002152000) (#2027408661c1)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_16-b01
  Java Home               = C:\Program Files\Java\jdk1.6.0_16\jre
  System Locale; Encoding = nl_BE (nb); Cp1252
  Home Directory          = C:\Documents and Settings\Eigenaar
  Current Directory       = C:\Program Files\NetBeans 6.9M1
  User Directory          = C:\Documents and Settings\Eigenaar\.netbeans\6.9m1
  Installation            = C:\Program Files\NetBeans 6.9M1\nb
                            C:\Program Files\NetBeans 6.9M1\ergonomics
                            C:\Program Files\NetBeans 6.9M1\ide
                            C:\Program Files\NetBeans 6.9M1\java

GUEST: testing selenium test files




Stacktrace: 
org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher$FileLockRemainedException: Lock file still present! C:\DOCUME~1\aglybin\LOCALS~1\Temp\customProfileDirf072f40108cd4d5ea47e70a256cdd472\parent.lock
   at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.waitForFileLockToGoAway(FirefoxChromeLauncher.java:269)
   at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.waitForFullProfileToBeCreated(FirefoxChromeLauncher.java:309)
   at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.populateCustomProfileDirectory(FirefoxChromeLauncher.java:106)
   at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.launch(FirefoxChromeLauncher.java:83)
   at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.launchRemoteSession(FirefoxChromeLauncher.java:350)
   at org.openqa.selenium.server.BrowserSessionFactory.createNewRemoteSession(BrowserSessionFactory.java:357)
Comment 1 aaaandruha 2010-05-05 08:41:27 UTC
Created attachment 98470 [details]
stacktrace
Comment 2 protomors 2010-08-24 22:14:16 UTC
*** Bug 187338 has been marked as a duplicate of this bug. ***
Comment 3 protomors 2010-08-24 22:29:20 UTC
I had the same problem. It is because Selenium server 1.0.1 does not support Firefox 3.6.
To solve this I simply downloaded latest version of Selenium and replaced %UserProfile%/.netbeans/6.9/modules/ext/selenium/selenium-server-1.0.1.jar
Selenium server bundled with plugin should be updated.
Comment 4 markmills 2010-09-14 15:32:15 UTC
Selenium has fixed this issue in Selenium Server 1.0.3. If the NetBeans plug-in is updated to this version of the Selenium Server, it *should* fix this issue. For now we are running Selenium RC instead of using the plug-in supplied server so we can do compatibility testing with FireFox.
Comment 5 smmandar 2010-12-15 13:48:15 UTC
@markmills@netbeans.org 
Thx Mark thats tricky one. I did as you have mentioned.
But one question here.
My selenium server version is 1.0.3 
and file name is selenium-server.jar

and in netbeans the selenium server is stored with version number as:
"selenium-server-1.0.1.jar" i copied new version to same directory and renamed the old version to "xyz_selenium-server-1.0.1.jar" and new version to "selenium-server-1.0.1.jar" and luckily its working. 
Actually its version 1.0.3 sever running but the file name is "selenium-server-1.0.1.jar". Can anyone tell me that How can configure netbeans so that it will point to  "selenium-server-1.0.3.jar" and not "selenium-server-1.0.1.jar" 
any xml file configuration for the same. 
This is because you the jar file is of version 1.0.3 and but its renamed to "1.0.1" because netbeans reads this file only.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo