Bug 18548 - Cannot execute from keyboard when output window active
Cannot execute from keyboard when output window active
Status: CLOSED WORKSFORME
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Windows ME/2000
: P4 (vote)
: 6.x
Assigned To: akemr
ivan
:
: 18549 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-12 00:53 UTC by luckyjim
Modified: 2008-12-23 08:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luckyjim 2001-12-12 00:53:53 UTC
I have mapped F6 to Execute Project (Ctrl Shift F6 is still assigned) and have
selected the main class for the project.

I compile something with F9, after compilation the Output Window is selected,
when I hit F6 or Shift-Ctrl-F6 nothing happens.  If I select another window, F6
works.
Comment 1 _ ttran 2001-12-12 08:42:16 UTC
you must choose the editor pane or the node of the class you want to
execute.  If the focus is elsewhere how the IDE can know what you want
to execute?
Comment 2 _ ttran 2001-12-12 08:42:54 UTC
*** Issue 18549 has been marked as a duplicate of this issue. ***
Comment 3 luckyjim 2001-12-14 03:59:07 UTC
I am using the "execute project" not "execute" command from the 
keyboard.  It should not matter which window I have active.  I have a 
project main class and that is the one that should be run.  This used 
to work and it was only when I went to 3.3 rc1 did I notice 
this "bug."  It now happens in the proper release also.

It is  annoying because I am used to pressing F9 then shift-ctrl-F6 
(or just F6 since I have changed that to "execute project").  Now, I 
often press F9, have to click, say on the editor window with a non-
main class in the window, then press F6 and the main class is 
executed.

It happens when I get a couple of Note: lines in the output window, a 
deprecation warning in my case; the output window is then made 
active.  So it matters which file I am pressing F9 for despite the 
fact that it does compile correctly.  It is not consistant.

I don't mean to be picky, I think that netbeans is a fantastic 
development environment.
Comment 4 Jan Zajicek 2001-12-14 14:03:52 UTC
Passing to Ales to check if terminal emulator can somehow involve
this. Feel free to reassign accordingly.
Comment 5 akemr 2001-12-14 14:26:57 UTC
Strange, I cannot reproduce this behaviour - it
worjks fine for me.

Could you please once again describe reproducing steps?
Thanks.
Comment 6 luckyjim 2001-12-14 23:12:11 UTC
Great!  Now I can't reproduce it at will, damn.  This has been 
bugging me for days.  I think that the Note: warnings were a red 
herring as it is currently working fine.

Do you want to suspend this and I will add another note when I can 
reliably reproduce it?
Comment 7 akemr 2001-12-15 09:54:56 UTC
Sure, I'm marking it as WORKSFORME, so if you reproduce it again,
feel free to REOPEN it :-)
Comment 8 Lukas Hasik 2002-03-22 16:06:58 UTC
verified
Comment 9 Quality Engineering 2003-07-01 16:15:48 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 10 Quality Engineering 2008-12-23 08:10:21 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo