Bug 185213 - org.netbeans.modules.editor.settings.storage.preferences.PreferencesImpl.flushTask locks
org.netbeans.modules.editor.settings.storage.preferences.PreferencesImpl.flus...
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P4 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 192511 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 23:46 UTC by Exceptions Reporter
Modified: 2016-07-07 07:25 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (13.63 KB, application/nps)
2010-04-28 23:46 UTC, Exceptions Reporter
Details
nps snapshot (9.66 KB, application/nps)
2010-04-29 13:11 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-04-28 23:46:16 UTC
Build: NetBeans IDE 6.9 Beta (Build 201004200117)
VM: OpenJDK Client VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_0-b16
OS: Linux

User Comments:
GUEST: Switched tabs from 8 to 4 spaces.

GUEST: I didn't see anything strange, but program says low performance

aldobrucale: Starting nb

darbie: I had just cut and pasted 3 lines of code to move them up a few lines in the source code of my C++ file.



Maximum slowness yet reported was 5354 ms, average is 3910
Comment 1 Exceptions Reporter 2010-04-28 23:46:23 UTC
Created attachment 98233 [details]
nps snapshot
Comment 2 Exceptions Reporter 2010-04-29 13:11:18 UTC
Created attachment 98279 [details]
nps snapshot
Comment 3 David Strupl 2012-03-20 14:04:09 UTC
org.netbeans.modules.editor.settings.storage.preferences.PreferencesImpl.flushTask locks and the get operation on the preferences is
stuck until the flushSpi() method finishes which can take a long time.
Comment 4 David Strupl 2012-03-20 14:11:33 UTC
Number of reports over the years --> P4.
Comment 5 David Strupl 2012-03-20 15:10:33 UTC
*** Bug 192511 has been marked as a duplicate of this bug. ***
Comment 6 Martin Balin 2016-07-07 07:25:47 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo