Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 185117 - [69cat] JSF library choice ignored
[69cat] JSF library choice ignored
Status: RESOLVED DUPLICATE of bug 207053
Product: javaee
Classification: Unclassified
Component: JSF
6.x
PC Linux
: P4 (vote)
: 7.2
Assigned To: Martin Fousek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 15:59 UTC by gholmer
Modified: 2012-04-16 08:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
framework selection during project creation (47.54 KB, image/png)
2010-04-27 16:00 UTC, gholmer
Details
frameworks in project properties after creation (22.57 KB, image/png)
2010-04-27 16:08 UTC, gholmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gholmer 2010-04-27 15:59:41 UTC
[ BUILD # : 201004270201 ]
[ JDK VERSION : 1.6.* ]

1) create new web project, select GlassFish V3 as server and JEE5 as Java EE
version
2) for framework select JSF
3) in lower portion of the same dialog ("JavaServer Faces Configuration"),
select "Registered Libraries" radio button and select ICEfaces 1.8.2 library
created earlier by the user
4) screen now looks like first attachment
5 [details]) allow project to be created, then open properties and select Frameworks (see
second attachment, "Registered Libraries" is now deselected in favor of "Use
default library which comes with server (JSF 2.0)".

I tried this also with GlassFish V2 as the server.
Comment 1 gholmer 2010-04-27 16:00:38 UTC
Created attachment 98151 [details]
framework selection during project creation
Comment 2 gholmer 2010-04-27 16:08:33 UTC
Created attachment 98152 [details]
frameworks in project properties after creation
Comment 3 Alexey Butenko 2010-05-25 10:16:10 UTC
library choice is not ignored as you can see from Libraries folder of the project, but in project properties it is not shown since it is disabled. Not a stopper for 6.9
Comment 4 Erno Mononen 2010-10-13 11:21:19 UTC
Taking over Alexey's JSF and Spring issues.
Comment 5 Petr Jiricka 2011-01-17 16:43:59 UTC
I agree this is just a minor UI glitch, not a functionality problem -> P4.
Comment 6 Martin Fousek 2012-04-16 08:28:57 UTC
Sorry I didn't find this issue before, so I'm marking this as duplicate of newer one. Anyway, this problem was fixed.

*** This bug has been marked as a duplicate of bug 207053 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo