Bug 18506 - Deadlock after switch to project with 2 opened forms
Deadlock after switch to project with 2 opened forms
Status: CLOSED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
All All
: P1 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-10 17:03 UTC by Marian Mirilovic
Modified: 2003-06-30 18:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Full thread dump (12.12 KB, text/plain)
2001-12-10 17:05 UTC, Marian Mirilovic
Details
integrated fix (1.27 KB, text/plain)
2001-12-10 18:19 UTC, Tomas Pavek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2001-12-10 17:03:14 UTC
[nb_release330](200112092330) with patch18489.jar in it 
on [jdk1.4](89)

Steps to reproduce:
- open MemoryView and Clock form files
- create New Project
- switch back to Default project
-> IDE freeze (full thread dump in attachment)

Patch is available on http://www.netbeans.org/issues/show_bug.cgi?id=18489 .

We start with issue on Form module, feel free to reassigne.
Comment 1 Marian Mirilovic 2001-12-10 17:05:36 UTC
Created attachment 3762 [details]
Full thread dump
Comment 2 Marian Mirilovic 2001-12-10 17:14:29 UTC
It's reproducible on [jdk1.3.1](01) too

The same result for IDE runns under Windows 2000.
Comment 3 Tomas Pavek 2001-12-10 18:19:48 UTC
Created attachment 3763 [details]
integrated fix
Comment 4 Tomas Pavek 2001-12-10 18:22:02 UTC
Fixed in NB 3.3.0.
FormDesigner.java rev. 1.48.6.1
Comment 5 Tomas Pavek 2001-12-10 18:25:58 UTC
So fixed...
Comment 6 Marian Mirilovic 2001-12-11 09:38:16 UTC
verified in [nb_release330](200112102331)

Verified on Windows2000/Solaris5.8  and [jdk1.3.1](01)/[jdk1.4](89)
Comment 7 Tomas Pavek 2001-12-11 13:55:00 UTC
Fixed also in dev and 3.3.1.
Comment 8 Quality Engineering 2003-06-30 18:27:21 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo