Bug 185047 - "Build zip distribution" fails for minimal rcp application (error in harness\suite.xml:342)
"Build zip distribution" fails for minimal rcp application (error in harness\...
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
PC Windows 7 x64
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
:
Depends on: 188601
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 20:40 UTC by carlo.salinari
Modified: 2010-07-12 15:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description carlo.salinari 2010-04-26 20:40:06 UTC
Product Version: NetBeans IDE 6.9 Beta (Build 201004200117)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

steps to reproduce:
- make new project nb platform application
- open project properties, Libraries
- uncheck the platform node
- expand the platform node, check
    + Bootstrap
    + File System API
    + Lookup
    + Module System API
    + Startup
    + Utilities API
- press ok
- try "Build zip distribution"

expected:
- the zip distribution

result:
- build fails, below is the content of the output window

branding:
Created dir: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\cluster
Building zip: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\cluster\core\locale\core_suite23.jar
Building zip: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\cluster\modules\locale\org-netbeans-core-windows_suite23.jar
files-init:
release:
Created dir: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\cluster\config\Modules
Hidden modules: [Actions APIs, Actions SPI (Experimental), Apache's Felix OSGi Implementation, Apple Application Menu, Auto Update Services, Auto Update UI, Command Line Parsing API, Common Annotations, Compatibility APIs, Core, Core - Execution, Core - UI, Core - Windows, Datasystems API, Dialogs API, ETable and Outline, Execution API, Explorer & Property Sheet API, Favorites, General Queries API, I/O APIs, I/O UI, JNA, JUnit 4, JavaHelp Integration, Keymap Options, Keyring API, Look & Feel Customization Library, MIME Lookup API, MIME Lookup On SystemFS, Master Filesystem, MultiView Windows, Native Access, NetBeans OSGi Integration, NetBeans in OSGi Runtime, Nodes API, OSGi Specification, Old Enumeration API, Options Dialog and SPI, Output Window, Print, Progress API, Progress UI, Quick Search API, RCP Platform, Scripting API Integration, Settings API, Settings Options API, Swing Layout Extensions integration, Tab Control, Text API, UI Utilities API, Visual Library API, Window System API]
build:
No sub-builds to iterate on
build-launchers:
Created dir: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\launcher\etc
Created dir: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\launcher\bin
Copying 1 file to C:\Users\carlo\Documents\NetBeansProjects\suite23\build\launcher\bin
Warning: Could not find file C:\Program Files\NetBeans 6.9 Beta\harness\launchers\app_w.exe to copy.
Copying 1 file to C:\Users\carlo\Documents\NetBeansProjects\suite23\build\launcher\bin
Copying 1 file to C:\Users\carlo\Documents\NetBeansProjects\suite23\build\launcher\etc
build-zip:
Created dir: C:\Users\carlo\Documents\NetBeansProjects\suite23\dist
No sub-builds to iterate on
C:\Program Files\NetBeans 6.9 Beta\harness\suite.xml:342: C:\Users\carlo\Documents\NetBeansProjects\suite23\build\null802978978 does not exist.
BUILD FAILED (total time: 1 second)
Comment 1 tomwheeler 2010-04-26 20:48:06 UTC
I can reproduce this under the following environment:

Product Version: NetBeans IDE 6.9 Beta (Build 201004200117)
Java: 1.6.0_18; Java HotSpot(TM) Client VM 16.0-b13
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: C:\Documents and Settings\twheeler\.netbeans\6.9beta

If you create a new platform app using the NetBeans Platform Application wizard, you *can* successfully build a ZIP distribution. It's only when you remove modules as Carlo described that it fails.
Comment 2 tomwheeler 2010-04-26 22:20:49 UTC
I was able to reproduce this in 6.8 too.  The root of the problem seems to be that, in this case, the only modules which are included are those which appear somewhere other than the modules directory (e.g. core, lib).

Carlo: Until this is fixed, a workaround is to include an additional module.  Something like UI Utilities or JUnit 4, which which doesn't do much and has no other dependencies, would be a good choice.  This will allow you to build a ZIP distribution.
Comment 3 Jesse Glick 2010-04-26 23:24:01 UTC
core-main #ed6a902e180f
Comment 4 Quality Engineering 2010-04-28 05:00:10 UTC
Integrated into 'main-golden', will be available in build *201004280200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:
Comment 5 tomwheeler 2010-04-29 16:43:27 UTC
Verified using the following environment:

Product Version: NetBeans IDE Dev (Build 201004280200)
Java: 1.6.0_20; Java HotSpot(TM) Client VM 16.3-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo