Bug 184448 - [69cat] Output window tabs do not get focus
[69cat] Output window tabs do not get focus
Status: RESOLVED DUPLICATE of bug 167908
Product: platform
Classification: Unclassified
Component: Output Window
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
: REGRESSION
Depends on: 184894
Blocks: 162159
  Show dependency treegraph
 
Reported: 2010-04-19 13:11 UTC by aldobrucale
Modified: 2013-08-26 15:13 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aldobrucale 2010-04-19 13:11:21 UTC
[ BUILD # : 201004190200 ]
[ JDK VERSION : 1.6.* ]

Actions like compiling, running or debugging a project used to bring forward
the output window tab: in nb 6.9 it doesn't happen any more.
Comment 1 David Strupl 2010-04-20 08:35:34 UTC
I think this is rather disturbing for the users. Making it P2 ...
Comment 2 David Simonek 2010-04-20 09:33:11 UTC
Regression? I didn't make any changes to output in 6.9... Surely it did work in 6.8?
Comment 3 David Strupl 2010-04-20 09:44:36 UTC
AFAIK it did work (at least on my OS). We have just tried trunk on linux and the it behaves bad there as well so I think it is not OS dependent.
Comment 4 Stanislav Aubrecht 2010-04-20 09:45:55 UTC
running/debugging a plain java project (ms windows, java 1.6) does activate
output window

running/debugging a netbeans module doesn't activate output window
Comment 5 David Strupl 2010-04-20 11:14:19 UTC
I am more concerned with compiling - I want to know what was printed during the compilation of any type of project ...
Comment 6 David Strupl 2010-04-20 11:34:59 UTC
I have just tested 6.8: the difference is that in 6.8 the output tab was reused when e.g. building different project. In 6.9 I am getting more tabs and the active tab is not being selected when the compilation/running is writing to it.
Comment 7 aldobrucale 2010-04-20 13:37:56 UTC
In my case it the tab doesn't get the focus even for plain java projects (but I also have open RCP projects in the explorer window).

Another action affected by this bug is "Apply code changes".
Comment 8 matthies 2010-04-28 19:00:14 UTC
Same here (Windows XP). If for example "Search Results" has focus, then doing Build or similar doesn't (re-)activate the Output Window.
It really throws you off (in addition to being inconvenient).
Comment 9 alied 2010-04-28 19:20:10 UTC
I have 6.8, 6.9Beta and 6.9dev.
in both 6.9, the output does not get activated. I have it minimized to the left, however if I click or hover on it, it correctly activates and shows the output.
Changed OS to All.

Product Version: NetBeans IDE Dev (Build 201004280200)
Java: 1.6.0_20; Java HotSpot(TM) Client VM 16.3-b01
System: Windows Vista version 6.0 running on x86; Cp1252; en (nb)
Userdir: C:\Users\Administrador\.netbeans\dev
Comment 10 Stanislav Aubrecht 2010-04-29 14:44:30 UTC
after some digging i've found out that the regression is caused by the fix for #162159 - the default value for 'options - misc - ant - always show output' has changed from true to false in that fix.

you can turn that option on manually to restore '6.8' behavior of output window.

reassigning to jesse for evaluation.
Comment 11 Stanislav Aubrecht 2010-04-29 14:51:40 UTC
picked the wrong platform when reassigning
Comment 12 Jesse Glick 2010-04-29 15:22:30 UTC
Right, you can turn on Always Show Output if you like. The default is intentionally off (it was accidentally broken in some previous releases).

Note that an implementation of bug #184894 would permit the Ant module to front the new tab even with this checkbox off, without necessarily opening the entire Output Window.

(In reply to comment #5)
> I want to know what was printed during the
> compilation of any type of project

The default behavior, by intent, is that the Output Window is not displayed if compilation succeeds. If there is an error, the tab is shown, scrolled to the error.

(In reply to comment #6)
> in 6.8 the output tab was reused
> when e.g. building different project. In 6.9 I am getting more tabs

Tabs are reused (assuming you do not uncheck the option for this), but only for completed builds; if you have another build running, then a second tab is opened.
Comment 13 David Strupl 2010-04-29 19:29:27 UTC
Will the final state be that after compilation the output will be visible? I don't insist on the output window to have focus --- just that I see what the compiler gave me during the build.

> Right, you can turn on Always Show Output if you like. The default is
> intentionally off (it was accidentally broken in some previous releases).

If this mean that the output is totally invisible by default I don't agree with that. Who has decided that "it is intentionally off"? Was it one of our UI experts? How the hell will the user find the option under "ant" category? How can the user tell that the compilation has finished? By looking at the progress indicator?
Comment 14 Jesse Glick 2010-04-29 19:53:16 UTC
(In reply to comment #13)
> Will the final state be that after compilation the output will be visible?

By default, no, unless there was some compilation error.

> Who has decided that "it is intentionally off"? Was it one of our UI experts?

Yes, see original issue.

> How will the user find the option under "Ant" category?

Well, if they can't find it under Tools > Options, there is also a button on the Output Window tab for Ant to open this page.

> How can the user tell that the compilation has finished?
> By looking at the progress indicator?

That, plus the status message "Finished building <whatever>".
Comment 15 arataj 2013-01-23 11:54:14 UTC
In 7.2, Ant's option "Always show output" does not work after a debugging session is started and a breakpoint is hit. In fact, the Output window, even if selected, invariably loses focus to the Variables window. As the usual reason for starting a debugging session is probably to stop at a breakpoint, then in a sense, "Always show output" has no effect for such a typical debugging session.

By the way, in the case of larger apps, the output window, even in the case of a run session, sometimes gets focused after many seconds of the app being run already, what forces the user, that does not want to wait to see that window's contents, to select it manually anyway.
Comment 16 Jaroslav Havlin 2013-08-26 15:13:37 UTC
(In reply to arataj from comment #15)
> By the way, in the case of larger apps, the output window, even in the case
> of a run session, sometimes gets focused after many seconds of the app being
> run already, what forces the user, that does not want to wait to see that
> window's contents, to select it manually anyway.
This seems to be the same problem as described in bug 167908.
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 167908 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo