Bug 184436 - "Build bundles" does not include bundles from external cluster
"Build bundles" does not include bundles from external cluster
Status: RESOLVED WORKSFORME
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks: 179473
  Show dependency treegraph
 
Reported: 2010-04-19 11:11 UTC by Tomas Danek
Modified: 2010-04-26 15:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2010-04-19 11:11:12 UTC
Product Version: NetBeans IDE 6.9 Beta (Build 201004142028)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
Userdir: C:\Users\tester\.netbeans\6.9beta

- created netbeans platform app
- added external cluster with one osgi bundle
- created osgi bundle and nbm project in the suite
-"build bundles" invoked on the suite built content of the suite + platform cluster, but nothing from external cluster.
Comment 1 Jaroslav Tulach 2010-04-20 07:51:25 UTC
Where is "build bundles" action?
Comment 2 Jesse Glick 2010-04-20 17:42:53 UTC
Just tried it and it worked for me.

.....
suite-osgi.build:
Created dir: /tmp/test184436/build/osgi
Prescanning JARs...
Skipping /space/src/nb/main/nbbuild/netbeans/platform/modules/org-netbeans-core-netigso.jar
Skipping /space/src/nb/main/nbbuild/netbeans/platform/modules/org-netbeans-libs-felix.jar
Skipping /space/src/nb/main/nbbuild/netbeans/platform/modules/org-netbeans-libs-osgi.jar
Processing /space/src/nb/main/nbbuild/netbeans/platform/core/core.jar into /tmp/test184436/build/osgi/org.netbeans.core.startup-101.25.0.100420-e0b35b449167.jar
.....
Processing /space/src/nb/main/nbbuild/netbeans/platform/modules/org-openide-windows.jar into /tmp/test184436/build/osgi/org.openide.windows-6.33.0.100420-e0b35b449167.jar
Copying 1 file to /tmp/test184436/build/osgi
Copying /home/jglick/NetBeansProjects/test184434/build/cluster/modules/bundle.jar to /tmp/test184436/build/osgi/bundle-1.0.jar
Processing /home/jglick/NetBeansProjects/test184434/build/cluster/modules/regular.jar into /tmp/test184436/build/osgi/regular-1.0.0.100420.jar
BUILD SUCCESSFUL (total time: 3 seconds)

where /tmp/test184436/nbproject/platform.properties has:

cluster.path=\
    ${nbplatform.active.dir}/platform:\
    ../../home/jglick/NetBeansProjects/test184434/build/cluster
Comment 3 Tomas Danek 2010-04-26 13:21:07 UTC
mine platform.properties has

cluster.path=\
    ${nbplatform.active.dir}/platform:\
    ../../../Desktop/m1

i.e. I used really external cluster.

Output shows:

...
Processing C:\Program Files\NetBeans Dev 201004260200\platform\modules\org-openide-windows.jar into C:\Users\tester\Documents\NetBeansProjects\suite3\build\osgi\org.openide.windows-6.33.0.201004260200.jar
Processing C:\Users\tester\Documents\NetBeansProjects\suite3\build\cluster\modules\m2.jar into C:\Users\tester\Documents\NetBeansProjects\suite3\build\osgi\m2-1.0.0.100426.jar
Copying 1 file to C:\Users\tester\Documents\NetBeansProjects\suite3\build\osgi
Copying C:\Users\tester\Documents\NetBeansProjects\suite3\build\cluster\modules\o1.jar to C:\Users\tester\Documents\NetBeansProjects\suite3\build\osgi\o1-1.0.jar
Processing C:\Users\tester\Documents\NetBeansProjects\suite3\build\cluster\core\locale\core_suite3.jar into C:\Users\tester\Documents\NetBeansProjects\suite3\build\osgi\core_suite3.jar
Processing C:\Users\tester\Documents\NetBeansProjects\suite3\build\cluster\modules\locale\org-netbeans-core-windows_suite3.jar into C:\Users\tester\Documents\NetBeansProjects\suite3\build\osgi\org-netbeans-core-windows_suite3.jar
BUILD SUCCESSFUL (total time: 12 seconds)

I'd expect to copy modules contained in my external m1 cluster to build/osgi folder.
If i understand correctly, osgi folder is intended to take and put into osgi container as is.
Comment 4 Jesse Glick 2010-04-26 15:21:21 UTC
(In reply to comment #3)
> I used really external cluster.

So did I: /home/jglick/NetBeansProjects/test184434/build/cluster is not inside /tmp/test184436.

> I'd expect to copy modules contained in my external m1 cluster to build/osgi
> folder.

So would I, so if you can figure out why it is not working for you (by debugging the Ant script or identifying minimal conditions which cause the problem to appear), let me know.

> If i understand correctly, osgi folder is intended to take and put into osgi
> container as is.

I'm not sure I understood that sentence, but the behavior is as follows:

1. All clusters in the cluster path - platform, suite, external - are scanned for modules, and information collected about them.

2. Any modules which turn out to be OSGi bundles are copied unmodified to build/osgi.

3. Regular modules are translated to bundle equivalents in build/osgi.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo