Bug 184223 - I18N : component names are garbled on ml installer
I18N : component names are garbled on ml installer
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All All
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@installer
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 06:56 UTC by Masaki Katakai
Modified: 2010-04-28 11:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (70.47 KB, image/png)
2010-04-15 06:56 UTC, Masaki Katakai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2010-04-15 06:56:11 UTC
Created attachment 97406 [details]
screenshot

I'm now trying Beta ml installer on Windows and Solaris,

  builds/netbeans/6.9/beta/2010-04-14_20-28-32/ml/bundles/

It seems that all localized component names are garbled,
unicode ascii (¥uXXXX) are being displayed as they are.
Other UIs are OK.

If you don't have Japanese environment, try --locale ja option.

I haven't much updated installer messages so I think
the problem exists in installer side.

Please let me know your evaluation and possibility
for bugfix at Beta.
If we can not fix it quickly (for Beta), I'll try to
revert all components names to English as workaround.
Comment 1 Alexei Mokeev 2010-04-15 09:58:36 UTC
Workaround is implemented by Masaki for Beta.
The fix is going to be done by FCS.
Comment 2 dlipin 2010-04-28 00:32:55 UTC
The issue is actually the regression after my fix in main #128dc7ed964d, in particular [1] and [2].

Actually that commit allows to build RCP Installers when the application title (app.title in nbproject/project.properties) and the path to the project contain Unicode chars.

But it also raised this issue: after looking into it it seems that LoadLocales [3] ant task handles properties loaded from <basename>.properties and <basename>_<locale>.properties in a different way: in partucular, it additionally convert property value to ascii if the property is loaded from <basename>_<locale>.properties. And that is apparently wrong (should be handled the same way for default, and for locale-specific .properties file).

[1] http://hg.netbeans.org/main/diff/128dc7ed964d/nbi/infra/build/.ant-lib/src/org/netbeans/installer/infra/build/ant/GroupDescriptor.java
[2] http://hg.netbeans.org/main/diff/128dc7ed964d/nbi/infra/build/.ant-lib/src/org/netbeans/installer/infra/build/ant/ProductDescriptor.java
[3] http://hg.netbeans.org/main/file/tip/nbi/infra/build/.ant-lib/src/org/netbeans/installer/infra/build/ant/LoadLocales.java
Comment 3 dlipin 2010-04-28 11:38:54 UTC
fixed in core-main#0e3ed2cceec8


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo