Bug 18421 - NPE during ide startup
NPE during ide startup
Status: VERIFIED FIXED
Product: contrib
Classification: Unclassified
Component: Sysprops
3.x
Sun SunOS
: P2 (vote)
: 3.x
Assigned To: sysprops@contrib
sysprops@contrib
:
: 18545 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 16:09 UTC by Jan Zajicek
Modified: 2001-12-17 10:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.25 KB, text/plain)
2001-12-06 16:10 UTC, Jan Zajicek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Zajicek 2001-12-06 16:09:24 UTC
3.3.0, rc1 build,
jdk1.4.0-rc-b88
version of sysprops - 1.1 dev-16


Download syprops from AU - from this time you will get always attached NPE
during ide startup. System properties node isn't in the runtime tab.
Comment 1 Jan Zajicek 2001-12-06 16:10:45 UTC
Created attachment 3716 [details]
stacktrace
Comment 2 Jesse Glick 2001-12-06 16:31:33 UTC
Caused in some sense by dstrupl's 1.47 to AbstractNode which changed
this node's behavior; previously AN.name would initially be null, now
it is "".

Fixed:

1.3 sysprops/src/org/netbeans/modules/sysprops/PropertyNode.java

Robert you may want to publish a new version of sysprops (just rebuild
from trunk sources). It ought to work with earlier NB versions as
well.
Comment 3 Jesse Glick 2001-12-13 13:46:30 UTC
*** Issue 18545 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2001-12-14 17:47:10 UTC
Fixed version is on AU, thanks Robert.
Comment 5 Jan Zajicek 2001-12-17 10:35:41 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo