Bug 184207 - [69cat] IDE deadlocked
[69cat] IDE deadlocked
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P2 (vote)
: 7.0
Assigned To: issues@editor
issues@editor
linewrap
: RANDOM, THREAD
: 184227 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-14 19:32 UTC by misterm
Modified: 2010-06-17 03:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stack trace (17.00 KB, text/plain)
2010-04-14 19:33 UTC, misterm
Details
stack trace (16.77 KB, text/plain)
2010-04-16 16:23 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2010-04-14 19:32:21 UTC
IDE got completely frozen. Memory usage was fine, so attaching thread dump.

Product Version = NetBeans IDE Dev (Build 100414-3e6cc34b4640)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_04
Runtime = Java HotSpot(TM) Client VM 10.0-b19
Comment 1 misterm 2010-04-14 19:33:47 UTC
Created attachment 97391 [details]
stack trace
Comment 2 Peter Pis 2010-04-15 07:41:36 UTC
Reassigning, please evaluate.
Comment 3 Peter Pis 2010-04-15 08:11:48 UTC
*** Bug 184227 has been marked as a duplicate of this bug. ***
Comment 4 Miloslav Metelka 2010-04-15 08:27:47 UTC
IMO we should first read-lock the document even in the HighlightingManager (possibly both the old and new one in case of document property change). Vito what do you think?
Comment 5 Vitezslav Stejskal 2010-04-15 11:12:56 UTC
Umm, I'm not sure, but I'll have a look.
Comment 6 misterm 2010-04-16 16:21:52 UTC
Just happened again. Attaching stack trace.
Comment 7 misterm 2010-04-16 16:23:17 UTC
Created attachment 97551 [details]
stack trace
Comment 8 misterm 2010-04-16 16:24:23 UTC
If I am not mistaken, both times I had just invoked CVS -> Diff and it got locked a couple of seconds later. I am pretty sure this is what I did for the most recent one.
Comment 9 Miloslav Metelka 2010-06-16 12:49:14 UTC
Fixed by doing doc.render() around rebuildAll().

http://hg.netbeans.org/jet-main/rev/0fcfc85dca98
Comment 10 Quality Engineering 2010-06-17 03:17:53 UTC
Integrated into 'main-golden', will be available in build *201006170001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0fcfc85dca98
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #184207 - IDE deadlocked - HighlightingManager versus Document's read-lock.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo