Bug 183962 - EDT is blocked by GsfReformatTask trying to acquire the parser lock while scanning is in progress
EDT is blocked by GsfReformatTask trying to acquire the parser lock while sca...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
6.x
All All
: P2 (vote)
: 7.2
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 199907 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 06:57 UTC by sjoerdmaessen
Modified: 2012-04-15 13:23 UTC (History)
87 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-04-13 06:57 UTC, sjoerdmaessen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sjoerdmaessen 2010-04-13 06:57:41 UTC
This bug was originally marked as duplicate of bug 174198, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201004120251)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows XP

User Comments:
sjoerdmaessen: Openend the settings panel



Maximum slowness yet reported was 105204 ms, average is 105204
Comment 1 sjoerdmaessen 2010-04-13 06:57:48 UTC
Created attachment 97137 [details]
nps snapshot
Comment 2 Dusan Balek 2011-11-07 18:09:15 UTC
EDT is blocked by GsfReformatTask trying to acquire the parser lock while
scanning is in progress.
Comment 3 Dusan Balek 2011-11-07 18:10:28 UTC
*** Bug 199907 has been marked as a duplicate of this bug. ***
Comment 4 David Strupl 2012-03-20 09:38:28 UTC
Dusane, can you please have a look? It has almost 600 reports in the exception reporter ... BTW isn't this fixed in the trunk by the recent changes? If not, it should be fixed for 7.2 --> P2.
Comment 5 Dusan Balek 2012-03-23 15:26:05 UTC
Since scanning is performed asynchronously now with transactional index, GsfReformatTask no more waits for it. Closing as FIXED.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo