Bug 183937 - Action in Maven RCP module shown with empty name at runtime
Action in Maven RCP module shown with empty name at runtime
Status: NEW
Product: apisupport
Classification: Unclassified
Component: Maven
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Martin Kozeny
issues@apisupport
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-12 16:15 UTC by Antonin Nebuzelsky
Modified: 2014-01-10 09:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Exception (3.46 KB, text/plain)
2010-04-12 16:15 UTC, Antonin Nebuzelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2010-04-12 16:15:01 UTC
Created attachment 97110 [details]
Exception

My local build 100412-db5178d59a01 from today.

1) created a new Maven NetBeans Application project set, including an empty module
2) added an Action to the module
3) built the NetBeans Platform Application project using Build action
4) ran the NetBeans Platform based Application project using Run action

The action added in step 2 is present in the UI, but has an empty name in the app's main menu. The console shows an exception (see the attachment here).

CTL_SomeAction key was added by the Action wizard in Bundle.properties of the module.
Comment 1 Antonin Nebuzelsky 2010-04-13 12:23:54 UTC
The behavior seems somewhat random. I tried reproducing several times and only once I was able to see the problem again and rebuild of the application fixed it. I did not find out why.
Comment 2 David Simonek 2010-04-19 16:18:00 UTC
I can reproduce, but I'm looking at it with disbelief :-) as Bundle.properties and layer.xml are correctly generated IMHO. There must be smt hidden...
Comment 3 Antonin Nebuzelsky 2010-05-10 15:02:30 UTC
Jaro, can you help us find reproducible steps for this issue?
Comment 4 Jaroslav Pospisil 2010-05-11 12:15:01 UTC
I don't think we need new reproducible steps,since I'm able to reproduce issue with steps you have provided. My prerequisites contains also clean userdir and deleted .m3 directory, though.
Comment 5 Jaroslav Pospisil 2010-05-11 12:15:31 UTC
I meant .m2 directory, of course ;-)
Comment 6 Antonin Nebuzelsky 2010-05-11 13:26:04 UTC
I found a case when I am able to reproduce the problem consistently.

When I do a change to a module (e.g. mavenapplicationtest-module1) and rebuild only that module (action Build on mavenapplicationtest-module1), then subsequent Run of the Platform based Application project manifests this bug.

After I rebuild with dependencies the Platform base Application project, next Run is OK.
Comment 7 David Simonek 2010-05-17 11:31:42 UTC
My observations are that the bug is really random and perhaps building of binaryFS cache may be at fault. The bug disappears whenever Bundle file is modified and module is rebuilt and in case of non-empty real world actions, this bug is not reproducible at all.

Lowering to P3 and marking as random.
Comment 8 David Simonek 2010-05-17 12:08:02 UTC
Note that artifacts/jars created seems to be OK, as bug can be reproduced randomly with the same set of jars, just by running created App from command line.

I tried to debug into BinaryFS, but without success. However it seems that for some reason Bundle.properties is not parsed well - most probability of bug occurrence seems to be when bundle key is on the very first place of Bundle.properties.
Comment 9 Jaroslav Tulach 2010-06-10 15:32:18 UTC
apisupport's usage of BinaryFS is does not count as a filesystems error. I am not sure if it is more module system or independent problem. I can just note that I've already suggested the apisupport to copy BinaryFS and modify it according to their needs.
Comment 10 Jesse Glick 2010-06-10 21:31:26 UTC
I don't understand comment #9 at all; comment #8 indicates that this is not an apisupport issue, so it is either a bug in BinaryFS or in module resource caches - right?
Comment 11 Martin Kozeny 2014-01-10 09:36:53 UTC
Reassigning to maven


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo