Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 183746 - NullPointerException at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.modifyMap
NullPointerException at org.netbeans.modules.java.JavaDataLoader$JavaFileEntr...
Status: RESOLVED DUPLICATE of bug 123006
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-09 06:45 UTC by Exceptions Reporter
Modified: 2010-04-09 06:57 UTC (History)
17 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.72 KB, text/plain)
2010-04-09 06:45 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-04-09 06:45:18 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP

User Comments:
lhasik: the exception appeared when creating new CDC application on CDC TK platform

crosati: Creating a new JFrame form

dagvin: Error generated when i use wizard to include JFrame in my application.
With netbeans 6 beta 2 i don't have this problem!

mishela: i wrote a statement
new LotteryGUI().setVisible(true);
then I clicked "create class LotteryGUI()" on the right
and then I deleted this class because I wanted to create JFrame form.
I clicked on the package and choosed New -> JFrame form, typed the name of the form and clicked next, then the new class was created, but that was not JFrame class, but empty class with the same name and the error has occured.

shaunhicks01: Created a brand new Java Application project for a quick test.

Attempted to create a new JFrame Form and immediately got this error.

Using 6.0-rc2.

dagvin: Problem with Wizard JFrame insert in my application. Beta 2 don't have this.

GUEST: Creating a new JFrame Form in a Java Application Project. I have been filling in the nlassname and pressing finish and nothing happend.

GUEST: insert in my project a JFrame class for building a interface swing application

mattwrock: I am trying to create a new JFrame in an existing project

GUEST: Creating a new JPanel Form

Class is created but it's empty. There is no code generated

howlingmadhowie: creating a new JForm

kmcowan: I was creating a new frame component

eaili: Creating a new JFrame.

GUEST: Everytime when I want to create new file of type "Form" (e.g. Swing Panel Form or Swing Frame Form) the exception occurs. Empty "java" file is being created but no form file. Also the dialog of creating new file disables the "Finish" button and only "Cancel" is available.

lleverich: Attempting to create a JDialog based form

howlingmadhowie: using the wizard to create a JApplet from the Swing GUI components

GUEST: When create a form class it will raise exception.
the java file will create but there nothing in the file

GUEST: GWT4NB doesn't work at NB6.0RC1 . . . Please help ! ! !

GUEST: I tried to create a new JPanel GUI form. This popped up when I pressed finish in the wizard.

howlingmadhowie: creating a new JFrame class

GUEST: Everytime when I want to create new file of type "Form" (e.g. Swing Panel Form or Swing Frame Form) the exception occurs. Empty "java" file is being created but no form file. Also the dialog of creating new file disables the "Finish" button and only "Cancel" and "Back" is available.

carmarthen: I was trying to create and add simple JPanel form.After clicking on 'Finish' button, class was created at right package but completly empty (no package, constructor etc inside). In addtion this exception was thrown.

GUEST: On Creating a new MDI Swing form.

mattwrock: I was trying to create a new JFrame in an existing project

GUEST: 
This seems to happen with any java code templates with shadow files. (E.g. JFrames, JForms, JApplets etc.)
i've just deleted my .netbeans directory in $HOME and restarted the IDE. now i can create Swing and Awt files again.

eaili: Creating JFrames.

wadechandler: I was trying to create a simple Swing JPanel in a NetBeans Module (RCP/Platform). I used the new file wizard, selected the type Swing...|JPanel..., and when I clicked Finish after typing in the name NodeParameter1_0 or NodeParameter (either one) the wizard never closed and I had a red error in the status bar.

lleverich: Creating a new JForm class

crosati: Creating a matisse JFrame form




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.modifyMap(JavaDataLoader.java:256)
   at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.createFormat(JavaDataLoader.java:207)
   at org.netbeans.modules.java.IndentFileEntry.createFromTemplate(IndentFileEntry.java:121)
   at org.netbeans.modules.java.JavaDataLoader$JavaFileEntry.createFromTemplate(JavaDataLoader.java:313)
   at org.openide.loaders.MultiDataObject.handleCreateFromTemplate(MultiDataObject.java:707)
   at org.openide.loaders.DataObject$CreateAction.run(DataObject.java:1247)
Comment 1 Exceptions Reporter 2010-04-09 06:45:30 UTC
Created attachment 96940 [details]
stacktrace
Comment 2 Marian Mirilovic 2010-04-09 06:56:17 UTC
All exceptions were thrown in 6.0 code base - WORKSFORME
Comment 3 Jan Lahoda 2010-04-09 06:57:07 UTC
Duplicate of bug #123006.

*** This bug has been marked as a duplicate of bug 123006 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo