Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 183420 - *Doxygen*: 'No documentation found' for module.GetUnits in Quote
*Doxygen*: 'No documentation found' for module.GetUnits in Quote
Status: RESOLVED INVALID
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 19:05 UTC by dnikitin
Modified: 2010-04-06 11:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
documentation is not shown in popup dialog (163.64 KB, image/png)
2010-04-02 19:05 UTC, dnikitin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dnikitin 2010-04-02 19:05:34 UTC
Created attachment 96619 [details]
documentation is not shown in popup dialog 

Product Version: NetBeans IDE Dev (Build cnd-main-3127-on-100329)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Linux version 2.6.28-18-generic running on i386; UTF-8; en_US (nb)
------------------------------------------------------------------

-- add module.cc in Quote sample project
-- add doxygen command for GetUnits() 
-- find line 
output << "Number of sub-modules: " << module.GetUnits() << endl;

-- invoke code completion for GetUnits
==> pop-up dialog shows 'No documentation found' (see attachment)
Comment 1 Thomas Preisler 2010-04-05 20:30:00 UTC
It is actually not a bug. Common practice is to put Doxygen documentation in the header file where the declaration is and not in the source file where the implementation is. The reason is the header file is viewed by the user where as the source usually is not. So, add you comments in module.h just before GetUnit and it works just fine when code complete GetUnit. 

Will close as INVALID but I will ask Vladimir V to see if he has any comments. We could probably also look where the function is implemented but it raises some issues with what if it is documented both places. Which one do you prefer?

Vladimir, please comment and reopen if you think we should also look where the  function is implemented.
Comment 2 Vladimir Voskresensky 2010-04-06 11:33:35 UTC
Thomas, you are right. doxygen documentation is applied to declarations not impl.
Btw, doxygen tool would not generate such documentation as well.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo