Bug 183330 - NullPointerException at org.netbeans.modules.profiler.heapwalk.model.ObjectNode$1.computeChildren
NullPointerException at org.netbeans.modules.profiler.heapwalk.model.ObjectNo...
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
EXCEPTIONS_REPORT
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-01 09:21 UTC by mklaehn
Modified: 2010-05-26 11:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.42 KB, text/plain)
2010-04-01 09:21 UTC, mklaehn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mklaehn 2010-04-01 09:21:03 UTC
This bug was originally marked as duplicate of bug 157335, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build nbms-and-javadoc-4950-on-100308)
VM: Java HotSpot(TM) Server VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Windows XP

User Comments:
mklaehn: navigating heapdump by keyboard

View: Fields in Instances View

pressing right arrow key in on node for java.util.HashMap -> this -> table -> ANY index that has value "null"




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.profiler.heapwalk.model.ObjectNode$1.computeChildren(ObjectNode.java:165)
   at org.netbeans.modules.profiler.heapwalk.model.BrowserUtils$1$1.run(BrowserUtils.java:231)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1356)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1894)
Comment 1 mklaehn 2010-04-01 09:21:07 UTC
Created attachment 96506 [details]
stacktrace
Comment 2 Jiri Sedlacek 2010-05-07 16:15:21 UTC
Thanks for catching it! Easily reproducible according to the provided steps.
Comment 3 Jiri Sedlacek 2010-05-07 16:37:57 UTC
Fixed in profiler-main:


http://hg.netbeans.org/profiler-main/rev/cc7e4f69e06f
Comment 4 Quality Engineering 2010-05-10 09:12:32 UTC
Integrated into 'main-golden', will be available in build *201005100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo