Bug 183327 - Support for Hibernate 3.5 as a JPA 2 provider
Support for Hibernate 3.5 as a JPA 2 provider
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Persistence
6.x
All All
: P2 with 6 votes (vote)
: 6.x
Assigned To: Sergey Petrov
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-01 08:37 UTC by Petr Jiricka
Modified: 2014-02-08 21:06 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2010-04-01 08:37:22 UTC
Hibernate 3.5 was just released with JPA 2 support: http://in.relation.to/Bloggers/Hibernate350FinalRelease

We should support it as a persistence provider for JPA 2.0.
Comment 1 Sergey Petrov 2010-04-01 08:45:39 UTC
should we also replace currently bundled hibernate with new one?
Comment 2 Petr Jiricka 2010-04-01 09:19:59 UTC
I am not quite sure. One thing is that the Hibernate framework support (non-JPA style) is in maintenance mode for this release, and we should not do anything that has a risk of destabilizing it. I am not sure if the config file format has changed, or...
Next, when we support more versions, we should consider implementing a config UI in the Web Frameworks panel that allows the user to use their own version of the library (not just the bundled one), like we do for JSF.

Is there a way to support Hibernate 3.5 as a JPA 2 provider, without replacing the bundled jars?
Comment 3 Petr Jiricka 2010-04-01 09:20:36 UTC
Sorry, this is meant to be enhancement, not defect.
Comment 4 Sergey Petrov 2010-04-01 09:31:12 UTC
I'll try to find out if it can be done relatively fast to support new persitence library with new hibernate, there are some issues with persistence libraries(may affect) and some updates  are required in hibernate provder.
Comment 5 Sergey Petrov 2010-04-01 10:21:43 UTC
now bundled hibernate is shown as "hibernate (jpa 1.0)" but if I create custom hibernate library from "new pu wizard" from hibernate 3.5 jars, new item "hibernate(jpa 2.0)" will appear. tried a bit in j2se and all seems ok, there is minor issue in web project in pu visual designer as hibernate (jpa1.0) is shown instead of "hibernate (jpa 2.0)" but it may have no side effect. please try to see if except this issue current support is enough.

http://hg.netbeans.org/web-main/rev/a8d7f8e69c74
Comment 6 Petr Jiricka 2010-04-01 12:20:13 UTC
Thanks a lot, Sergey, I will try. Another aspect of the support may be to support Hibernate's annotation processor for generating the canonical metamodel.
Comment 7 Quality Engineering 2010-04-02 04:51:29 UTC
Integrated into 'main-golden', will be available in build *201004020200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a8d7f8e69c74
User: Sergey B. Petrov <sj-nb@netbeans.org>
Log: fix#183327 some part  to support both hibernate jpa 1.0 and hibermnate jpa 2.0
Comment 8 David Konecny 2010-04-06 21:13:20 UTC
(In reply to comment #2)
> Next, when we support more versions, we should consider implementing a config
> UI in the Web Frameworks panel that allows the user to use their own version of
> the library (not just the bundled one), like we do for JSF.

Yes. And similarly for Spring. Perhaps list of frameworks should be changed to table with two columns where second column shows version. The version would be a combo box listing all available versions including custom ones. It could also contain an option at the bottom of combo box popup "Register new library". Just an idea. It would have implications on current UI and may require too many changes though.
Comment 9 giovannicandido 2011-02-13 23:15:32 UTC
The hibernate 3.6.1 has release.
Comment 10 bht 2011-05-22 06:40:22 UTC
I tried to create a new persistence unit with Build 201105050000, but Hibernate JPA 2.0 cannot be selected. In libraries, "Hibernate JPA" still seems to be old.
Comment 11 catweasle 2011-07-06 13:57:58 UTC
Since this did not make it into NB 6.9, please change the target milestone.
Comment 12 catweasle 2011-07-06 14:38:03 UTC
(In reply to comment #11)
> Since this did not make it into NB 6.9, please change the target milestone.

I can get hibernate / jpa2 by adding the hibernate 3.6 libraries myself as in comment #5. bug 190800 is a duplicate of this one targeted at NB 7 (and still open as well). Isn't it time to bundle a more recent release of hibernate than 3.2.5?
Comment 13 Sergey Petrov 2011-07-06 15:11:13 UTC
yes, hibernate is supported as jpa2.0 provider(need to add new library) now but to bundle newer version a lot of hibernate specific(not jpa) related functionality may need to be updated (hql editor etc.)
Comment 14 Is_this_a_joke 2012-03-31 06:22:00 UTC
Wow, 2 years old and no support for the latest version of Hiberate? Hibernate, the most used ORM framework? 

Netbeans is the flaming pile of dog shit it's always been. Continue writing substandard garbage. It's why you're a fucking joke.
Comment 15 Petr Jiricka 2012-04-02 08:18:17 UTC
We appreciate your interest in the Hibernate support in NetBeans, but please refrain from using offensive language in comments. This is not ethical.
Comment 16 catweasle 2014-02-08 21:06:33 UTC
Netbeans 7.4 contains hibernate 3.6/JPA 2 support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo