Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 18312 - Cancel beans autoloading, move Timer bean
Cancel beans autoloading, move Timer bean
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: Tomas Pavek
issues@guibuilder
:
: 13815 14258 (view as bug list)
Depends on: 31843
Blocks: 21979
  Show dependency treegraph
 
Reported: 2001-12-03 17:51 UTC by Tomas Pavek
Modified: 2002-04-08 17:46 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Pavek 2001-12-03 17:51:35 UTC
Beans "autoloading" feature should be canceled (it installs automatically beans 
from jars just placed in "beans" directory). It does not seem to be used 
anyway, and it causes problems by mounting jars during startup (see issue 
14258). We will rely on openide (projects) that the correct jars are always 
mounted. The preferred way of installing beans in jars is using xml layer by 
modules.

According to this, Timer bean cannot be "autoloaded", but should installed 
through the xml layer too. I don't think it should be done in Form module. 
Timer is just an example bean, used by another examples which are already 
placed in usersguide module. So the Timer bean should be moved to usersguide 
module too. Together with the move, issue 13815 should be fixed (not to start 
the Timer in constructor; this requires also to modify ClockFrame example).
Comment 1 Tomas Pavek 2001-12-03 17:58:10 UTC
*** Issue 14258 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Pavek 2001-12-03 18:00:28 UTC
*** Issue 13815 has been marked as a duplicate of this issue. ***
Comment 3 Tomas Pavek 2002-04-08 16:02:04 UTC
I'm ready to move the Timer bean to usersguide module. Do 
usersguide people agree with it (see the reasons above)?

The move includes:
- moving TimerBean.jar (appears in netbeans/beans dir),
- moving sources (appears in netbeans/sources dir),
- modifying layer.xml and UGModule.java, adding 
timerbean.xml - to mount TimerBean.jar automatically,
- modifying layer.xml and Bundle.properties to add Timer 
to component palette.
Comment 4 Patrick Keegan 2002-04-08 16:11:56 UTC
Fine with me, especially since sampledir already is part of 
usersguide.
Comment 5 Tomas Pavek 2002-04-08 17:46:00 UTC
Thanks, Patrick...
Comment 6 Tomas Pavek 2002-04-08 17:46:47 UTC
... done.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo