Bug 183064 - debugger - Socket Exception occurred
debugger - Socket Exception occurred
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Linux
: P1 with 2 votes (vote)
: 6.x
Assigned To: rmatous
issues@php
:
: 173147 183302 184221 184957 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-29 12:11 UTC by antonx
Modified: 2010-06-24 15:12 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
the index.php file to step though + nb logs + xdebug log (21.70 KB, application/zip)
2010-03-29 12:11 UTC, antonx
Details
screencapture of "Socket Exception" with no way of exiting except killing netbeans (4.48 MB, application/octet-stream)
2010-05-21 00:09 UTC, ussher
Details
xdebug.remote_log output file generated when the socket exceptions happen (743.06 KB, text/plain)
2010-05-25 10:07 UTC, ussher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description antonx 2010-03-29 12:11:46 UTC
Created attachment 96176 [details]
the index.php file to step though + nb logs + xdebug log

Here I restart a new bug report for http://netbeans.org/bugzilla/show_bug.cgi?id=180252 (which is getting too long)

I use the php nightly build from today:
netbeans-trunk-nightly-201003290201-php-linux.sh

Please step through the index.php file with F7 and you will get the error!

In the xdebug.log I can still see eval commands .. strange I thought there were gone.

Happy bug hunting ;-)

Anton
Comment 1 Filip Zamboj 2010-03-29 12:42:23 UTC
antonx configuration: 
php 5.3.1
NB 6.9
xdebug 2.1.0beta3 on opensuse 11.1 64bit
Comment 2 rmatous 2010-04-06 08:28:41 UTC
*** Bug 183302 has been marked as a duplicate of this bug. ***
Comment 3 Quality Engineering 2010-04-09 04:45:56 UTC
Integrated into 'main-golden', will be available in build *201004090201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d285fd9c84c6
User: Radek Matous <rmatous@netbeans.org>
Log: #183064 - debugger - Socket Exception occurred
Comment 4 rmatous 2010-04-09 08:59:01 UTC
fixed
Comment 5 Filip Zamboj 2010-04-16 14:29:17 UTC
*** Bug 184221 has been marked as a duplicate of this bug. ***
Comment 6 jellobird 2010-04-29 16:59:54 UTC
Socket exception still occures with NetBeans IDE 6.9 Beta.

If Tools > Options > PHP > Debugging > Watches and Baloon Evaluation is checked this error code pops up.

My php setup:
---
ubuntu x86_64

PHP Version 5.3.2-0.dotdeb.2 (/etc/apt/sources.list: deb http://php53.dotdeb.org stable all)

Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Xdebug v2.0.5, Copyright (c) 2002-2008, by Derick Rethans
    with Suhosin v0.9.31, Copyright (c) 2007-2010, by SektionEins GmbH
===
Comment 7 rmatous 2010-05-03 07:54:23 UTC
Tools > Options > PHP > Debugging > Watches and Baloon Evaluation

This options was added because of "Watches and Baloon Evaluation" are not reliable after "eval" command. Switching it on is dangerous and after enabling it you should be informed about it by disclaimer. So, I don't accept it as a bug because I believe the problem isn't on our side (meaning netbeans <=> xdebug) and I don't see any way how to fix it.
Comment 8 ussher 2010-05-21 00:09:13 UTC
Created attachment 99283 [details]
screencapture of "Socket Exception" with no way of exiting except killing netbeans

With the latest nightly build of netbeans for php and the xdebug-beta (xebug 2.1) installed with pecl

$ sudo pecl install xdebug-beta

The Socket Exception is still happening.  It doesnt start immediately and for a while the debugger works well then after a time the socket exceptions just start.

Once they start there is no way to stop them other than killing netbeans with ctrl+alt+esc

There is a warning that also pops up.  All of the warnings and "Socket exception" errors have a title to the box, but nothing in the box itself.

This is a screencapture of the "Socket Exception" problem happening.  If left It will continue to add anonther and yet another to the screen.  I have left it until getting up to over 170 open alert notices before.
Comment 9 rmatous 2010-05-25 09:25:46 UTC
ussher, please could you add logging information:
http://wiki.netbeans.org/HowToConfigureXDebug#Enable_Xdebug_logging
Comment 10 ussher 2010-05-25 10:07:02 UTC
Created attachment 99423 [details]
xdebug.remote_log output file generated when the socket exceptions happen

sure can.  The contents of xdebug.log mean nothing to me.  Hopefully they are helpful to you.  I let the "Socket exception" errors get to up to about 180 before killing netbeans.  

Hopefully this is helpful.
Comment 12 Filip Zamboj 2010-05-27 16:41:07 UTC
v/c
Comment 13 Milan Kuchtiak 2010-05-27 16:49:58 UTC
The fix looks fine and harmless.
Comment 14 rmatous 2010-05-27 17:02:13 UTC
fixed into release69:
http://hg.netbeans.org/release69/rev/dcabdd5ea56d
Comment 15 Quality Engineering 2010-05-28 08:01:16 UTC
Integrated into 'main-golden', will be available in build *201005280001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ea73c4811e37
User: Radek Matous <rmatous@netbeans.org>
Log: #183064 - debugger - Socket Exception occurre
Comment 16 Filip Zamboj 2010-06-09 20:31:01 UTC
Product Version: NetBeans IDE 6.9 (Build 100609-a94d6a4a87fe)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01

verified in release69 clone.
Comment 17 rmatous 2010-06-14 14:31:37 UTC
*** Bug 184957 has been marked as a duplicate of this bug. ***
Comment 18 rmatous 2010-06-14 14:39:06 UTC
*** Bug 173147 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo