Bug 183039 - Reference Problem on creating Java Application
Reference Problem on creating Java Application
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Project
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-29 07:40 UTC by Ivan Sidorkin
Modified: 2010-04-17 08:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (43.13 KB, text/plain)
2010-03-29 07:42 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2010-03-29 07:40:17 UTC
Product Version: NetBeans IDE Dev (Build 201003290201)
Java: 1.6.0_18; Java HotSpot(TM) Client VM 16.0-b13
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)


full installation, empty userdir

- open some NB module from NB sources  (I use jemmy)
- wait until scan finished
- create Java Application

Reference Problem dialog appeared
Comment 1 Ivan Sidorkin 2010-03-29 07:42:33 UTC
Created attachment 96134 [details]
messages.log
Comment 2 Ivan Sidorkin 2010-03-29 07:43:45 UTC
restarting NB fix the problelm
Comment 3 Jesse Glick 2010-03-30 23:50:18 UTC
Never heard of such a problem and cannot reproduce. What reference problem?
Comment 4 Ivan Sidorkin 2010-03-31 06:14:53 UTC
reproduced on linux with Build 201003290201

reference problem: junit and junit_4 library could not found
Comment 5 Jesse Glick 2010-03-31 16:47:40 UTC
Sorry but I was not able to reproduce on Linux. If you can, please debug it. (Do those libraries in fact exist according to Library Manager?) Could be a bug in j2seproject somewhere etc. - I can't even guess.
Comment 6 Oleg Khokhlov 2010-04-01 13:11:57 UTC
reproduced on xp with Build 20100401
Comment 7 Jesse Glick 2010-04-02 15:40:08 UTC
Cannot reproduce using 100331 cluster.config=basic on XP. If you can only reproduce using the full IDE then you need to narrow down the problem to find who is responsible.
Comment 8 Ivan Sidorkin 2010-04-02 15:51:14 UTC
reproducible only if ergonomics enabled
Comment 9 Tomas Pavek 2010-04-06 16:17:21 UTC
I can reproduce this (in build 201004060201) even just by creating a new Java Application after starting full IDE with fresh userdir. Don't have to open NBM project.

After the project is created, it complains about missing junit_4 and junit libraries, and they are not visible under Test Libraries node of the project. But the libraries are there (in Library Manager), also libs.junit_4.classpath and libs.junit.classpath are properly defined in build.properties in userdir. I can also create and run a test. Reopening the project, or creating or opening another JavaSE project in this situation leads to same "reference problems" in that project. Only restart helps.

Get the same behavior if enable JavaSE in Tools|Plugins first after IDE start instead of letting that on FoD.

Given these facts it seems like some projects related problem.
Comment 10 Ivan Sidorkin 2010-04-15 08:57:48 UTC
reproduced with 
Product Version: NetBeans IDE 6.9 Beta (Build 201004142028)
Java: 1.6.0_18; Java HotSpot(TM) Client VM 16.0-b13
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

by creating Java Application on fresh installation with empty userdir
Comment 11 Tomas Zezula 2010-04-15 14:39:37 UTC
Seems as a race caused by FoD.
Comment 12 Tomas Zezula 2010-04-16 12:05:54 UTC
Fixed jet-main 2776269b99a3
Comment 13 Quality Engineering 2010-04-17 08:18:59 UTC
Integrated into 'main-golden', will be available in build *201004170515* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2776269b99a3
User: Tomas Zezula <tzezula@netbeans.org>
Log: #183039:Reference Problem on creating Java Application


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo