Bug 18269 - Work with the properties table causes data loss
Work with the properties table causes data loss
Status: CLOSED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: issues@utilities
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-03 09:29 UTC by Milan Kuchtiak
Modified: 2003-07-01 14:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kuchtiak 2001-12-03 09:29:47 UTC
This is the scenario :

- add 2 or more new Items to properties table (fill only key - let the value 
fields empty)
- edit those empty values in the table

Unfortumnately almost all new items disapear suddenly.
Comment 1 Martin Roskanin 2001-12-04 09:37:43 UTC
fixed in [maintrunk]

Rolling back previous changes

/cvs/properties/src/org/netbeans/modules/properties/Element.java,v  <--  Element.java
new revision: 1.25; previous revision: 1.24

/cvs/properties/src/org/netbeans/modules/properties/KeyNode.java,v  <--  KeyNode.java
new revision: 1.24; previous revision: 1.23

/cvs/properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java,v  <--  
PropertiesFileEntry.java
new revision: 1.38; previous revision: 1.37

/cvs/properties/src/org/netbeans/modules/properties/PropertiesParser.java,v  <--  
PropertiesParser.java
new revision: 1.26; previous revision: 1.25

/cvs/properties/src/org/netbeans/modules/properties/PropertiesStructure.java,v  <--  
PropertiesStructure.java
new revision: 1.31; previous revision: 1.30

Comment 2 Martin Roskanin 2001-12-04 09:48:45 UTC
fixed in [release33] too.

Rolling back previous changes

/cvs/properties/src/org/netbeans/modules/properties/Element.java,v  <--  Element.java
new revision: 1.24.2.1; previous revision: 1.24

/cvs/properties/src/org/netbeans/modules/properties/KeyNode.java,v  <--  KeyNode.java
new revision: 1.23.2.1; previous revision: 1.23

/cvs/properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java,v  <--  
PropertiesFileEntry.java
new revision: 1.37.2.1; previous revision: 1.37

/cvs/properties/src/org/netbeans/modules/properties/PropertiesParser.java,v  <--  
PropertiesParser.java
new revision: 1.25.2.1; previous revision: 1.25

/cvs/properties/src/org/netbeans/modules/properties/PropertiesStructure.java,v  <--  
PropertiesStructure.java
new revision: 1.30.2.1; previous revision: 1.30


Comment 3 Lukas Hasik 2001-12-04 14:58:52 UTC
 (Build 20011204-1123)

-verified, discussed with bug reporter (Milan)
Comment 4 Martin Roskanin 2001-12-04 17:33:07 UTC
fix has been integreated into [release330]

/cvs/properties/src/org/netbeans/modules/properties/Element.java,v  <--  Element.java
new revision: 1.24.4.1; previous revision: 1.24

/cvs/properties/src/org/netbeans/modules/properties/KeyNode.java,v  <--  KeyNode.java
new revision: 1.23.4.1; previous revision: 1.23

/cvs/properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java,v  <--  
PropertiesFileEntry.java
new revision: 1.37.4.1; previous revision: 1.37

/cvs/properties/src/org/netbeans/modules/properties/PropertiesParser.java,v  <--  PropertiesParser.java
new revision: 1.25.4.1; previous revision: 1.25

/cvs/properties/src/org/netbeans/modules/properties/PropertiesStructure.java,v  <--  
PropertiesStructure.java
new revision: 1.30.4.1; previous revision: 1.30



Comment 5 Martin Roskanin 2002-07-18 13:58:41 UTC
The fix of the issue #14634 again caused this problem. I used the
previous fix except the changes in PropertiesParser. I believed that
the changes in PropertiesParser caused this bug.  I have tested the
fix and because I didn't reproduced this bug I commited it.
Unfortunatelly the problem wasn't only in PropertiesParser. It seems,
that it is global problem, mainly caused by changes in
PropertiesStructure, but I am not sure. I think the best solution will
be roll back it again :-( There is no time to investigate the problem. 
Comment 6 Martin Roskanin 2002-07-18 15:42:52 UTC
fixed in [maintrunk]

Rolled back the changes made by bugfixing the issue #14634.
Peter, could you please review this fix? 
I would like to request for an integration to release 34.
Thanks.

DIFFs:

PropertiesStructure:
--------------------
fix of this issue:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/PropertiesStructure.java.diff?r1=1.34&r2=1.35
previous fix of #14634:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/PropertiesStructure.java.diff?r1=1.31&r2=1.32

KeyNode:
--------
fix of this issue:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/KeyNode.java.diff?r1=1.25&r2=1.26
previous fix of #14634:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/KeyNode.java.diff?r1=1.24&r2=1.25

Element:
--------
fix of this issue:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/Element.java.diff?r1=1.26&r2=1.27
previous fix of #14634:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/Element.java.diff?r1=1.25&r2=1.26

PropertiesFileEntry:
---------------------
fix of this issue:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java.diff?r1=1.39&r2=1.40
previous fix of #14634:
http://properties.netbeans.org/source/browse/properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java.diff?r1=1.38&r2=1.39


Comment 7 Peter Zavadsky 2002-07-19 08:52:25 UTC
It's just a rollback, so it should be fine.
Comment 8 pfelenda 2002-07-22 11:05:44 UTC
Verified in #200207190200. It works as expected.


Only comment : 

  After change in value field (in editor form), the value is not
visible cca 1-2 seconds. This is not so user friendly.
Comment 9 Martin Roskanin 2002-07-23 14:39:21 UTC
integrated into [release34]

/cvs/properties/src/org/netbeans/modules/properties/Element.java,v 
<--  Element.java
new revision: 1.26.8.1; previous revision: 1.26

/cvs/properties/src/org/netbeans/modules/properties/KeyNode.java,v 
<--  KeyNode.java
new revision: 1.25.8.1; previous revision: 1.25

/cvs/properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java,v
 <--  PropertiesFileEntry.java
new revision: 1.39.8.1; previous revision: 1.39

/cvs/properties/src/org/netbeans/modules/properties/PropertiesStructure.java,v
 <--  PropertiesStructure.java
new revision: 1.33.8.2; previous revision: 1.33.8.1
Comment 10 Quality Engineering 2003-07-01 14:20:48 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo