Bug 182439 - Java Debugger's working state is broken when vm crashes
Java Debugger's working state is broken when vm crashes
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
: THREAD, USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-21 02:05 UTC by dextml
Modified: 2010-05-13 13:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dextml 2010-03-21 02:05:23 UTC
[ISSUE]
Java Debugger's working state can be broken when some unexpected VM crashes occur.
When such crash occurs, Netbeans IDE is still partially working under "debugging mode" while the target program has already exited. Unless restart Netbeans, the broken state cannot be easily undone.


[REPRODUCE]
write a simple java app; tune the the VM flag to some unacceptable level, like -Xmx4096m; hit "Debug Main Project" or something similar; then, watch the outcome.


[TEMPORARY WORKAROUND]
Restart Netbeans.


[NOTE]
Tested on 6.8, 6.7, 6.5
Comment 1 Martin Entlicher 2010-03-22 10:42:45 UTC
I can occasionally reproduce this. It looks like a threading issue.
Comment 2 dextml 2010-03-22 11:39:42 UTC
(In reply to comment #1)
> I can occasionally reproduce this. It looks like a threading issue.

Weird. I can reproduce this everytime.
Comment 3 Martin Entlicher 2010-03-24 07:49:04 UTC
Fixed in changeset:   164613:b5e0cae01d11
http://hg.netbeans.org/main/rev/b5e0cae01d11
Comment 4 Quality Engineering 2010-04-02 05:09:45 UTC
Integrated into 'main-golden', will be available in build *201004020200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b5e0cae01d11
User: mentlicher@netbeans.org
Log: #182439 Improved the interruption and kill of the session in case of a failure.
Comment 5 Marian Mirilovic 2010-05-13 13:57:17 UTC
I am not able to reproduce it in NB 6.9 (201005122200)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo