Bug 182337 - Not refreshing .properties files when cleaning and building project
Not refreshing .properties files when cleaning and building project
Status: RESOLVED INCOMPLETE
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Petr Hejl
issues@serverplugins
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 21:50 UTC by the008
Modified: 2010-05-17 11:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description the008 2010-03-18 21:50:30 UTC
Hello folks!

I'm updating a JSP project using i18n (JSTL), loading the strings from .properties files. I'm having an issue that doesn't update the .properties files when I clean and build the project (neither when running inside IDE using Tomcat nor when building .war file). The source file is updated, but the copies (run folder and .war) are old files. I tried Netbeans versions 6.8 and 6.9 (dev).

My OS config is:
Product Version = NetBeans IDE Dev (Build 201003180200)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_16
Runtime = Java HotSpot(TM) Client VM 14.2-b01
Comment 1 Petr Jiricka 2010-03-24 16:51:28 UTC
Looks like another incarnation of bug 167170. Can I ask: 
- Is your project Ant-based or Maven-based?
- Can you try if this works if you change the server to GlassFish?
- Is the Deploy on Save checkbox in your project's properties dialog turned on?
- Where are the .properties files located? Are they under the Java sources?

Thanks.
Comment 2 Petr Jiricka 2010-04-08 08:26:55 UTC
Waiting for more information - incomplete for now.
Comment 3 Martin Schovanek 2010-05-17 11:40:55 UTC
Was trying to reproduce on JSTExaple project without success.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo