Bug 182301 - [69cat] JComponent.getFontMetrics can be very very slow
[69cat] JComponent.getFontMetrics can be very very slow
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT perf-profileme jdk_...
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 13:06 UTC by Michel Graciano
Modified: 2012-12-05 12:05 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-03-18 13:06 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2010-03-18 13:06:47 UTC
Build: NetBeans IDE Dev (Build 100317-4f4e9483a9f0)
VM: Java HotSpot(TM) Client VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Linux

User Comments:
GUEST: ???

Intel Core2DuoE7300 2.66G
2GB RAM
WinXP SP3

GUEST: nothing special ;-)

GUEST: initial startup. long delay on 'scanning projects'

GUEST: booting up netbeans



Maximum slowness yet reported was 29455 ms, average is 12644
Comment 1 Michel Graciano 2010-03-18 13:06:52 UTC
Created attachment 95368 [details]
nps snapshot
Comment 2 ares4322 2010-07-29 04:47:55 UTC
Build: NetBeans IDE 6.9 (Build 201006101454)
VM: Java HotSpot(TM) Client VM, 16.0-19, Java(TM) SE Runtime Environment,
1.6.0_19
OS: Linux

AMD Phenom2 2,5G
4GB RAM
Ubuntu 9.10

Long delay on startup and 'scanning projects'

Maximum slowness yet reported was 26000 ms, average is 12000 ms
Comment 3 Antonin Nebuzelsky 2011-01-18 14:41:01 UTC
Similar to what is reported in the following JDK bug. An attempt of a fix on JDK side has been integrated to JDK 7 a long time ago.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6421149
Comment 4 wilfred2760 2012-07-26 13:45:07 UTC
please kindly resolve this issue
Comment 5 reinouts 2012-12-05 10:24:19 UTC
I got a slowness exception with NB 7.3b2 and java version "1.7.0_09-icedtea" which was classified as a duplicate of this bug so clearly it has not been fixed completely.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo