Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 182112 - "Save actions" would be very useful
"Save actions" would be very useful
Status: RESOLVED DUPLICATE of bug 140719
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
All All
: P2 (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-16 13:38 UTC by nicolo
Modified: 2011-04-21 13:29 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicolo 2010-03-16 13:38:15 UTC
Implement "Save actions" like in Eclipse, in which you can choose what to do automatically on save of a java class:
These actions could be:
- Fix import
- Add @Override annotations
- Add final to private members if possible
- Remove trailing whitespace
- Add missing braces

There shoud a place where to configure what action to choose.
Comment 1 David Strupl 2011-04-21 13:29:27 UTC

*** This bug has been marked as a duplicate of bug 140719 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo