Bug 182092 - 7s - navigator initializes all its components even they are not visible
7s - navigator initializes all its components even they are not visible
Status: RESOLVED DUPLICATE of bug 172822
Product: platform
Classification: Unclassified
Component: Navigator
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-16 10:17 UTC by ostermann_bernd
Modified: 2010-03-29 16:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-03-16 10:17 UTC, ostermann_bernd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ostermann_bernd 2010-03-16 10:17:11 UTC
Build: NetBeans IDE Dev (Build 201002152000)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows XP

User Comments:
ostermann_bernd: Just opened Netbeans 6.9M1. NB was opening my projects



Maximum slowness yet reported was 8376 ms, average is 7213
Comment 1 ostermann_bernd 2010-03-16 10:17:18 UTC
Created attachment 95224 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2010-03-22 06:57:31 UTC
org.netbeans.modules.navigator.NavigatorTC.setPanels() takes a lot of time, delegating to two different subsystems:
org.netbeans.modules.java.navigation.ClassMemberPanelUI.<init>()
and
org.netbeans.modules.java.debug.ClasspathNavigatorProviderImpl.getComponent()

and also
org.netbeans.modules.beans.BeanPanel.getComponent()
but that is fast this time.
Comment 3 David Simonek 2010-03-29 16:31:47 UTC
Yes, more info in duplicate 172822

*** This bug has been marked as a duplicate of bug 172822 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo