Bug 18208 - Javabean Customizer image load fails
Javabean Customizer image load fails
Status: CLOSED DUPLICATE of bug 13038
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 00:23 UTC by Ben
Modified: 2003-06-30 18:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2001-11-30 00:23:39 UTC
While trying to open the customizer for the QuickTable javabean in the Swing 
Form, I am getting the following error.

In the customizer constructor, we are trying to load a gif file, which is 
located in the same directory where the customizer class is present in the jar 
file using the following code.

  ImageIcon imgIcon = new ImageIcon(this.getClass().getResource
("customize.gif"));

This customizer works fine in Jbuilder/IBm Visual age.

Exception:
Thu Nov 29 19:12:29 EST 2001: java.lang.NullPointerException: Posted StackTrace
Annotation: Exception occurred in Request Processor
org.openide.util.RequestProcessor$Holder: Posted StackTrace(task 
org.netbeans.core.ModuleActions$1@164690 [-16, 1, -1])
        at org.openide.util.RequestProcessor$Task.createHolder
(RequestProcessor.java:322)
        at org.openide.util.RequestProcessor.post(RequestProcessor.java:100)
        at org.openide.util.RequestProcessor.post(RequestProcessor.java:73)
        at org.netbeans.core.ModuleActions.invokeAction(ModuleActions.java:89)
        at org.openide.awt.Actions$ButtonBridge.actionPerformed
(Actions.java:351)
        at javax.swing.AbstractButton.fireActionPerformed
(AbstractButton.java:1450)
        at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed
(AbstractButton.java:1504)
        at javax.swing.DefaultButtonModel.fireActionPerformed
(DefaultButtonModel.java:378)
        at javax.swing.DefaultButtonModel.setPressed
(DefaultButtonModel.java:250)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:279)
        at 
javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased
(BasicMenuItemUI.java:886)
        at java.awt.Component.processMouseEvent(Component.java:3715)
        at java.awt.Component.processEvent(Component.java:3544)
        at java.awt.Container.processEvent(Container.java:1164)
        at java.awt.Component.dispatchEventImpl(Component.java:2593)
        at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:2451)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:2216)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2125)
        at java.awt.Container.dispatchEventImpl(Container.java:1200)
        at java.awt.Window.dispatchEventImpl(Window.java:914)
        at java.awt.Component.dispatchEvent(Component.java:2497)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:131)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)
 
Thu Nov 29 19:12:29 EST 2001: java.lang.NullPointerException: null
java.lang.NullPointerException
        at javax.swing.ImageIcon.<init>(ImageIcon.java:134)
        at quick.dbtable.DBTableCustomizer.<init>(DBTableCustomizer.java:63)
        at java.lang.Class.newInstance0(Native Method)
        at java.lang.Class.newInstance(Class.java:237)
        at org.netbeans.modules.form.RADComponentNode.getCustomizer
(RADComponentNode.java:355)
        at org.netbeans.core.NbNodeOperation.customize(NbNodeOperation.java:90)
        at org.openide.actions.CustomizeAction.performAction
(CustomizeAction.java:34)
        at org.openide.util.actions.NodeAction.performAction(NodeAction.java:92)
        at org.openide.util.actions.NodeAction.actionPerformed
(NodeAction.java:83)
        at org.netbeans.core.ModuleActions$1.run(ModuleActions.java:76)
        at org.openide.util.Task.run(Task.java:124)
[catch] at org.openide.util.RequestProcessor$ProcessorThread.run
(RequestProcessor.java:626)
Comment 1 Marian Mirilovic 2001-11-30 08:34:37 UTC
Ben,

this issue seems like fixed now, it's also duplicate of issue 13038.
Try to download new NetBeans 3.3. build, I hope it's fixed there. 
If you can report it on new version of NB, please REOPEN.
IMHO: This isn't P1, P1 - means critical and data lost.


Thanx for report.

*** This issue has been marked as a duplicate of 13038 ***
Comment 2 Quality Engineering 2003-06-30 18:20:55 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 3 Quality Engineering 2003-06-30 18:32:47 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo