Bug 18207 - Classcast exception while designing javabean in a swing form
Classcast exception while designing javabean in a swing form
Status: CLOSED DUPLICATE of bug 13884
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 00:10 UTC by Ben
Modified: 2003-06-30 18:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2001-11-30 00:10:39 UTC
Thu Nov 29 19:03:30 EST 2001: java.lang.ClassCastException: java.lang.Object
Annotation: Exception in org.netbeans.modules.form.FormPropertyEditor Property 
Editor.
java.lang.ClassCastException: java.lang.Object
        at sun.beans.editors.BoolEditor.getAsText(BoolEditor.java:33)
        at org.netbeans.modules.form.FormPropertyEditor.getAsText
(FormPropertyEditor.java:170)
        at 
org.openide.explorer.propertysheet.PropertyDisplayer.getReaderComponent
(PropertyDisplayer.java:405)
        at org.openide.explorer.propertysheet.PropertyDisplayer.setValue
(PropertyDisplayer.java:233)
        at org.openide.explorer.propertysheet.PropertyDisplayer.<init>
(PropertyDisplayer.java:167)
        at org.openide.explorer.propertysheet.PropertySheet.refreshTab
(PropertySheet.java:804)
        at org.openide.explorer.propertysheet.PropertySheet.setCurrentPage
(PropertySheet.java:498)
        at org.openide.explorer.propertysheet.PropertySheet.setCurrentPage
(PropertySheet.java:512)
        at org.openide.explorer.propertysheet.PropertySheet.refreshPropertySheet
(PropertySheet.java:658)
        at org.openide.explorer.propertysheet.PropertySheet.access$1500
(PropertySheet.java:68)
[catch] at org.openide.explorer.propertysheet.PropertySheet$14.run
(PropertySheet.java:1228)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:154)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:337)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:131)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)
Comment 1 Marian Mirilovic 2001-11-30 08:26:03 UTC

*** This issue has been marked as a duplicate of 13884 ***
Comment 2 Quality Engineering 2003-06-30 18:20:54 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 3 Quality Engineering 2003-06-30 18:32:46 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo