Bug 182013 - LowPerformance took 14923 ms.
LowPerformance took 14923 ms.
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Navigation
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 182718 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-15 09:21 UTC by Exceptions Reporter
Modified: 2013-05-17 08:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-03-15 09:21 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-03-15 09:21:38 UTC
Build: NetBeans IDE Dev (Build 201003140200)
VM: OpenJDK 64-Bit Server VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_18-b18
OS: Linux
Maximum slowness yet reported was 14923 ms, average is 14923
Comment 1 Exceptions Reporter 2010-03-15 09:21:43 UTC
Created attachment 95161 [details]
nps snapshot
Comment 2 David Strupl 2010-03-15 09:30:53 UTC
Hello,

please check similar fix here:

http://hg.netbeans.org/main/rev/8d9f9559cb00

The point is not to call getOpenedPanes (getEditorPane) in order not to cause the editor initialization when it is not ready. There should be alternative calls that will not cause the initialization and return null instead on NbDocument (findRecentEditorPane).
Comment 3 Leonid Lenyashin 2010-03-15 23:13:10 UTC
How did it get into QNavigator category? Should we go ahead and remove this category?
Comment 4 Vladimir Voskresensky 2010-03-16 07:09:43 UTC
our navigator is in cnd.qnavigator module
Comment 5 David Strupl 2010-03-16 07:37:01 UTC
I put it to that category based on package name. Feel free to move anywhere you like provided that someone from your team will have a look at it ;-)
Comment 6 Alexander Simon 2010-03-16 11:32:15 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/e682d213bbb6
Comment 7 Alexander Simon 2010-03-25 12:46:44 UTC
*** Bug 182718 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo