Bug 18179 - Clean Looks API
Clean Looks API
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Search
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: Jaroslav Tulach
issues@utilities
:
Depends on:
Blocks: 18177
  Show dependency treegraph
 
Reported: 2001-11-29 09:17 UTC by Jaroslav Tulach
Modified: 2002-02-04 12:36 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2001-11-29 09:17:14 UTC
There is a few classes that should not be public, also consider usage of
javax.swing.Action instead of SystemAction, because according to issue #17597
the SystemAction class is not general enough.
Comment 1 _ ttran 2001-11-29 15:52:42 UTC
not a bug => TASK
Comment 2 Jaroslav Tulach 2002-01-29 12:05:46 UTC
Mostly cleaned, now we need to resolve problem of persistence of
LookNodes and keeping their open state.
Comment 3 Jaroslav Tulach 2002-02-04 10:51:33 UTC
Cleaned.
Comment 4 Jesse Glick 2002-02-04 10:56:40 UTC
Any estimate as to when it will be considered more or less finalized
and ready to merge to the trunk?
Comment 5 Jaroslav Tulach 2002-02-04 12:36:36 UTC
I think it is stable and I would like to merge it soon (announced on
nbdev) - but when it will be part of main build depends on when
somebody will take its ownership.



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo