Bug 181314 - FreeBSD 7.0-8.0, with intel video drivers (2.7.1) text is distorted
FreeBSD 7.0-8.0, with intel video drivers (2.7.1) text is distorted
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
PC Other
: P3 (vote)
: 7.0
Assigned To: issues@platform
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-27 12:29 UTC by yerenkow
Modified: 2010-10-01 12:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Example of distorted text (162.55 KB, image/png)
2010-02-27 12:30 UTC, yerenkow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yerenkow 2010-02-27 12:29:44 UTC
See in many places:
License agreement, area shows normal, after I scroll - text is looking like at snapshot.

Also same effect are seen in code editor area, in some files, which have scrolling (big enough).

Note that eclipse, IDEA have no such issues, so it's probably due to different rendering method.

With such "issue", netbeans are almost unusable :(

I'll be glad to provide any info required, or run some tests at my PC.
Comment 1 yerenkow 2010-02-27 12:30:49 UTC
Created attachment 94596 [details]
Example of distorted text
Comment 2 Stanislav Aubrecht 2010-03-02 05:56:39 UTC
can you reproduce this problem also when running jdk's swingset demo?
Comment 3 yerenkow 2010-03-03 14:38:01 UTC
Okay, seems got this problem.

Same behavior in example Notepad and in SwingTest (I replaced one of sources to see how html is handled)

2179 lines = no problems,
2180 or more lines = problems (even if line is a single character).

Is this will help find some workaround, or you just leave this as "not our bug"?
Comment 4 Antonin Nebuzelsky 2010-10-01 12:03:00 UTC
You could possibly workaround the problem by setting some Java properties affecting how 2D drawing is done. Can you try the following and confirm here if it helped?

-J-Dsun.java2d.d3d=false

or more aggressively

-J-Dsun.java2d.noddraw=true

See more info at

http://download.oracle.com/javase/1.5.0/docs/guide/2d/flags.html

(you can set these properties either on command line or in netbeans.conf file in your NB installation)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo