Bug 181056 - [68cat] AssertionError: CloneableEditorSupport.getOpenedPanes() must be called from AWT thread only
[68cat] AssertionError: CloneableEditorSupport.getOpenedPanes() must be calle...
Status: RESOLVED DUPLICATE of bug 182697
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-22 15:31 UTC by Michel Graciano
Modified: 2010-03-31 21:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.45 KB, text/plain)
2010-02-22 15:31 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2010-02-22 15:31:37 UTC
Build: NetBeans IDE 6.8 (Build 200912041610)
VM: Java HotSpot(TM) Client VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Linux

User Comments:
hmichel: When switching between project groups

mailo: I was changing Project group




Stacktrace: 
java.lang.AssertionError: CloneableEditorSupport.getOpenedPanes() must be called from AWT thread only
   at org.openide.text.CloneableEditorSupport.getOpenedPanes(CloneableEditorSupport.java:1083)
   at org.netbeans.modules.db.sql.editor.ui.actions.ConnectionAction$ToolbarPresenter$1.getDefaultComponent(ConnectionAction.java:170)
   at javax.swing.SortingFocusTraversalPolicy.getFirstComponent(SortingFocusTraversalPolicy.java:447)
   at javax.swing.LayoutFocusTraversalPolicy.getFirstComponent(LayoutFocusTraversalPolicy.java:148)
   at javax.swing.SortingFocusTraversalPolicy.getDefaultComponent(SortingFocusTraversalPolicy.java:511)
   at javax.swing.SortingFocusTraversalPolicy.enumerateAndSortCycle(SortingFocusTraversalPolicy.java:131)
Comment 1 Michel Graciano 2010-02-22 15:31:44 UTC
Created attachment 94402 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2010-02-23 05:20:07 UTC
My guess is that org.netbeans.modules.project.ui.ProjectTab is at fault - manipulating swing components hierarchy from a listener that is called on a RP thread.
Comment 3 Jesse Glick 2010-03-31 21:56:58 UTC

*** This bug has been marked as a duplicate of bug 182697 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo