Bug 181037 - 78s - in maven.execute.ActionToGoalUtils.isActionEnable()
78s - in maven.execute.ActionToGoalUtils.isActionEnable()
Status: RESOLVED INCOMPLETE
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@projects
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-22 07:52 UTC by Exceptions Reporter
Modified: 2010-10-04 12:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-02-22 07:52 UTC, Exceptions Reporter
Details
nps snapshot (8.72 KB, application/nps)
2010-07-02 07:02 UTC, puppala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-02-22 07:52:14 UTC
Build: NetBeans IDE 6.8 (Build 200912091457)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP
Maximum slowness yet reported was 78297 ms, average is 78297
Comment 1 Exceptions Reporter 2010-02-22 07:52:21 UTC
Created attachment 94389 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2010-02-23 01:42:06 UTC
Possibly caused by network (slow or even broken) file access called from maven project action.
Comment 3 puppala 2010-07-02 07:02:18 UTC
Created attachment 100558 [details]
nps snapshot

Opened a context menu of a project node (in Projects). That project is a Maven project stored in a Clear Case VOB accessed using a CC dynamic view.

This happens every time.

Wasn't that slow in 6.8.
Comment 4 Antonin Nebuzelsky 2010-07-30 15:18:20 UTC
Reassigning to default owner.
Comment 5 Antonin Nebuzelsky 2010-09-24 12:50:49 UTC
All snapshots show the time is spent in java.io.WinNTFileSystem calls. Number of calls is not huge, just a few tens of them, but summed up they take the tens of seconds. I don't see a way to fix that because it is most probably caused by temporarily overloaded system filesystem.

puppala, please provide more information if you can. Where is your project stored (type of filesystem, latency of I/O on the network if it is on a network FS)? Is some other process on your machine doing intensive I/O at the time you see the problem?
Comment 6 puppala 2010-10-04 12:42:47 UTC
As I said, the project is a Maven 2 project stored in a Clear Case VOB. The Clear Case is a distributed one, so it is accessed via network. And yes, it sometimes causes access problems also outside NetBeans.

It would be interesting to know, what kind of file operations this case includes ? Sometimes in our environment it takes many seconds to e.g. right click a file in Clear Case Explorer.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo