Bug 180999 - Netbeans requests non-existing pages when debugging.
Netbeans requests non-existing pages when debugging.
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Windows 7 x64
: P1 with 2 votes (vote)
: 6.x
Assigned To: rmatous
issues@php
:
: 171040 178854 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-20 16:04 UTC by derickr
Modified: 2010-02-22 11:40 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description derickr 2010-02-20 16:04:48 UTC
If the variables page is selected, netbeans starts doing this:

<- property_get -i 10921 -n $this -c 0 -p 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="property_get" transaction_id="10921"><property name="$this" fullname="$this" address="49161064" type="object" classname="MyClass" children="1" numchildren="2" page="1" pagesize="31"><property name="CLASSNAME" type="string"><![CDATA[MyClass]]></property><property name="a" fullname="$this-&gt;a" facet="private" address="49154176" type="string" size="1" encoding="base64"><![CDATA[Yg==]]></property><property name="b" fullname="$this-&gt;b" facet="private" address="49161344" type="string" size="1" encoding="base64"><![CDATA[Yg==]]></property></property></response>

<- property_get -i 10922 -n $this -c 0 -p 2
-> <response ...

<- property_get -i 10923 -n $this -c 0 -p 3
-> <response ...

(and it continues increasing the page number until you deselect the variables page).
Obviously netbeans should try to ask for more pages than there are elements for—unfortunately the protocol doesn't specify that it should throw an error then, but I will change Xdebug to not return any properties.

(See also bug #180252)
Comment 1 antonx 2010-02-21 01:11:34 UTC
Thanks Derick for the gret job.

I changed the prio, because today
its just impossible to debug with netbeans,
at least with the configuration nb 6.8+php 5.3.1+linux.

... and we all know debugging is not a "nice to have" but 
something crucial (even if I know lot of people usinf print/echo
in the php domain to debug. A thing which is unthinkable
during c++ development where I came from)
Comment 2 derickr 2010-02-21 09:43:55 UTC
Alright, feel free to contact me through e-mail though. Discussing issues here is annoying :-)
Comment 3 rmatous 2010-02-22 01:36:26 UTC
Derick, thanks for the evaluation. I think there is a fixed duplicate #179533:
http://netbeans.org/bugzilla/show_bug.cgi?id=179533

logic behind the fix is:

if (numchildren > (page+1)*pageSize)
Comment 4 rmatous 2010-02-22 01:38:53 UTC
logic behind the fix is:

if (numchildren > (page+1)*pageSize)
  send("property_get -i 10923 -n $this -c 0 -p (page+1)")

can you review?
Comment 5 rmatous 2010-02-22 02:03:06 UTC
So, marking as duplicate #179533, please verify or easily reopen if doesn't work for you. Naturally any comment welcome.

Build with fix can be taken from:
http://bertram.netbeans.org/hudson/job/PHP-build/

*** This bug has been marked as a duplicate of bug 179533 ***
Comment 6 rmatous 2010-02-22 02:04:22 UTC
Filipe, please could you test it, thanks
Comment 7 rmatous 2010-02-22 08:25:22 UTC
*** Bug 171040 has been marked as a duplicate of this bug. ***
Comment 8 rmatous 2010-02-22 08:40:49 UTC
*** Bug 178854 has been marked as a duplicate of this bug. ***
Comment 9 ajinkya 2010-02-22 11:19:17 UTC
I have tested latest php build (NetBeans-dev-2010-02-22_18-04-20 -php.zip) and I still get into same problem (as in  Bug 180252). I can't debug on PHP Version 5.3.1 with xDebug 2.0.6-dev  on Windows 7 64bit .
Comment 10 rmatous 2010-02-22 11:40:57 UTC
to  ajinkya: if SocketException is thrown for you then please reopen #180252, if Netbeans requests non-existing pages when debugging(as reported here) then please reopen this issue.

Anyway, before reopening it please be sure that you use the latest xdebug (Xdebug 2.1.0beta2) - at least I would recommend it, definitely derick can give you better info which version of xdebug is needed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo