Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 180774 - beans.xml not created in Maven projects
beans.xml not created in Maven projects
Status: RESOLVED DUPLICATE of bug 220707
Product: javaee
Classification: Unclassified
Component: Maven
6.x
All All
: P3 with 1 vote (vote)
: 7.2
Assigned To: Martin Janicek
issues@javaee
:
: 181334 195688 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-16 05:33 UTC by Petr Jiricka
Modified: 2012-10-24 11:13 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2010-02-16 05:33:31 UTC
Ant-based web project has a checkbox for enabling CDI (creating beans.xml). Maven web project does not have anything like that - I guess we should make it consistent.
Comment 1 David Konecny 2010-02-28 16:19:18 UTC
*** Bug 181334 has been marked as a duplicate of this bug. ***
Comment 2 Petr Jiricka 2010-05-10 15:13:49 UTC
On the other hand, in Maven projects we do not normally allow customization of the project being created - it just follows the standard archetypes. One question is whether to include beans.xml in the archetype by default, so it is always present. But that may not be a good idea because of the following GlassFish bug: https://glassfish.dev.java.net/issues/show_bug.cgi?id=11668
Comment 3 viggonavarsete 2011-02-22 09:07:28 UTC
I think it shouldn't be created as default, but as an option when generating the project. I would look at all options in the wizard as changing the default (archetype), but I think this is ok.
Comment 4 Petr Jiricka 2011-02-22 09:30:20 UTC
*** Bug 195688 has been marked as a duplicate of this bug. ***
Comment 5 David Konecny 2011-02-22 23:50:37 UTC
So what do you guys suggest? The way I understand it is that this issue cannot be resolve until there is an archetype which generates beans.xml (always or conditionally).
Comment 6 viggonavarsete 2011-02-23 08:54:37 UTC
I think there are two options:
1. Conditional include/exclude of files during archetype generation
2. Have two archetypes, one with and one without beans.xml

In order to pick option 1 the following issues must be resolved (as far as I understand):
http://jira.codehaus.org/browse/ARCHETYPE-58
http://jira.codehaus.org/browse/ARCHETYPE-274

Which means, in the short term it looks like option 2 is the only way to achieve this.
Comment 7 Martin Janicek 2011-11-02 10:26:10 UTC
This is still valid issue, but there is probably no time to do so in 7.1. Setting TM --> Next.
Comment 8 Martin Janicek 2012-10-24 11:13:08 UTC

*** This bug has been marked as a duplicate of bug 220707 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo