Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 180672 - MakeNBM creates nbm with executable files stored in Info/executables.list but updater read Info/executable.list (missing 's')
MakeNBM creates nbm with executable files stored in Info/executables.list but...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: dlipin
au-issues
68patch2-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-12 10:06 UTC by Alexander Pepin
Modified: 2010-03-18 16:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2010-02-12 10:06:47 UTC
This is a regression introduced in patch1 after fixing bug #178201
Steps to reproduce:
- create Fractal sample project
- leave project properties "Console Type" and "Terminal Type" as Default
- run it, it runs successfully
- switch profiler off
- run the project
Result: "There was an error creating the child process for this terminal" window appears
Comment 1 Alexander Pepin 2010-02-27 09:39:54 UTC
It's reproducible on all platforms except Windows.
On Mac term window (dorun.sh) gives:
/usr/X11/bin/xterm: Can't execvp /Applications/NetBeans/NetBeans 6.8.app/Contents/Resources/NetBeans/cnd3/bin/dorun.sh: Permission denied
Comment 2 Alexander Pepin 2010-02-27 09:44:05 UTC
To rollback patch1 changes a user just need to reinstall nb6.8 and use a fresh userdir.
Comment 3 Vladimir Kvashin 2010-03-01 08:03:00 UTC
The reason is the absence of execution permissions for 
cnd3/bin/dorun.sh

I've just installed a fresh 6.8 - cnd3/bin/dorun.sh has execution permissions.
If I upgrade it to 6.8.1, i see that cnd3/bin/dorun.sh don't have execution permissions.

As soon as I set execution permissions for this file, the bug disappears.
Comment 4 Vladimir Kvashin 2010-03-01 08:23:28 UTC
When I build IDE from sources, cnd3/bin/dorun.sh execution permissions are set. So I believe the problem is in the installer.
Comment 5 dlipin 2010-03-01 15:07:58 UTC
The issue is that MakeNBM stores executable files info in
Info/executables.list
but updater read that information from
Info/executable.list

Fixed by using Info/executable.list in MakeNBM:
http://hg.netbeans.org/core-main/rev/7ddf91788e0d

Actually, should be reproducible on 6.9 dev builds as well within the following scenario:
1) Install 6.9 M1 JavaSE
2) Run IDE, open Tools->Plugins, install C/C++, restart
3) After restart cnd/bin/dorun.sh does not have executable permissions

Definitely needs to be back-ported to 6.8 (patch2).
Comment 6 rbalada 2010-03-08 06:58:50 UTC
Dima,

I tend to be afraid to backport a change in build infrastructure, which in fact means, that if it should really have to have an influence, then affected NBMs available from Update Center must be rebuilt and go through complete publishing cycle.

Please explain why we should not go with a fix rather in updater than in MakeNBM?

(I know about singular better than plural rule, but this rule seems to be much softer than what it means if we would have insisted on it)
Comment 7 dlipin 2010-03-09 05:17:18 UTC
I can't but agree with you, so reverting change in MakeNBM and doing that in autoupdate.services:
http://hg.netbeans.org/core-main/rev/244ed71aa63d
Comment 8 rbalada 2010-03-09 06:59:18 UTC
The patch looks good.
Comment 9 Quality Engineering 2010-03-10 23:13:21 UTC
Integrated into 'main-golden', will be available in build *201003110200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/244ed71aa63d
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Better fix for #180672 - fix updater rather than MakeNBM
Comment 10 rbalada 2010-03-16 19:43:28 UTC
The patch has been ported into release68_fixes repository as http://hg.netbeans.org/release68_fixes/rev/f8848d09917d
Comment 11 Alexander Pepin 2010-03-18 16:04:07 UTC
verified in patch2 candidate 20100318


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo