Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 180652 - [69cat] Messages in tooltip windows are truncated and not readable
[69cat] Messages in tooltip windows are truncated and not readable
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
6.x
PC All
: P2 (vote)
: 7.0
Assigned To: Vitezslav Stejskal
issues@editor
69patch1-verified
:
: 186767 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-12 05:22 UTC by Andrei Chistiakov
Modified: 2010-07-07 14:25 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (75.61 KB, image/png)
2010-02-12 05:22 UTC, Andrei Chistiakov
Details
Wrapped tooltip (52.28 KB, image/png)
2010-06-08 09:26 UTC, Vitezslav Stejskal
Details
Screenshot of 201006250001 (279.43 KB, image/jpeg)
2010-06-26 20:39 UTC, _ gtzabari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2010-02-12 05:22:52 UTC
Created attachment 94115 [details]
screenshot

Product Version: NetBeans IDE Dev (Build 201002110200)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

Messages in tooltip windows are truncated and not readable

See the attached screenshot
Comment 1 Anton Chechel 2010-04-01 13:40:28 UTC
error badging - yardus
Comment 2 J Bachorik 2010-04-02 10:20:22 UTC
Hints->karol
Comment 3 Karol Harezlak 2010-05-10 08:26:04 UTC
We dont cotrol rendering on of tooptip in our modules, we just pass test for hint/tooltip. As far I understand Tiptool size depends on size of the editor. In case editor is not big enough users are not able to see whole warning/error. This functionality (most likely) is on the Hints API side.
Comment 4 _ gtzabari 2010-05-27 00:22:47 UTC
I've increased the priority to P2 as I believe this is a serious regression relative to 6.8.

Furthermore, when a tooltip is too long to fit in the editor, the "+" on the left of the tooltip is unreachable. Normally it shows up right above the mouse button, but in this case it is all the way to on the left of the editor. It is very difficult to reach it without the tooltip closing.
Comment 5 Vitezslav Stejskal 2010-05-27 07:58:26 UTC
*** Bug 186767 has been marked as a duplicate of this bug. ***
Comment 6 _ gtzabari 2010-06-07 17:57:59 UTC
Correct me if I'm wrong, but doesn't this issue affect *all* tool-tips?

If you scroll the mouse over an variable doesn't its value get cut off too? If so, I believe this is a critical regression that should be fixed in 6.9.
Comment 7 Vitezslav Stejskal 2010-06-08 09:26:18 UTC
Created attachment 99887 [details]
Wrapped tooltip

I don't think that this affects all tooltips. I can't say which tooltips are affected and which are not, but IMO this is javafx specific. It's possible to use simplified HTML syntax in tooltips, which makes the long lines wrap as they would in a browser.

I have to have a closer look in order to say what exactly is the problem in this case. But I'm pretty sure that if there were the same problem in java we would have a P1 ticket for it.
Comment 8 matthies 2010-06-08 13:02:14 UTC
This is NOT javafx-specific. It also happens with tooltips on Java source code for example.
See also issue #99191. The problem seems to be tooltips with multiline content.
Comment 9 _ gtzabari 2010-06-09 19:50:11 UTC
If this applies to all tooltips (especially ones in the code editor) shouldn't this absolutely get fixed in 6.9?
Comment 10 Michel Graciano 2010-06-09 20:07:11 UTC
I can reproduce it for Ubuntu too.
Comment 11 Michel Graciano 2010-06-09 20:08:16 UTC
I reproduce it for a java free form project for a java file.
Comment 12 Vitezslav Stejskal 2010-06-11 10:34:15 UTC
Ok, I'll have a closer look. Let's mark it as 6.9.1 candidate.
Comment 13 rbalada 2010-06-22 07:49:38 UTC
Please report on progress, especially if you can make it into 6.9.1, if not please consider removing 6.9.1_CANDIDATE keyword.

Thanks,
-R
Comment 14 Vitezslav Stejskal 2010-06-24 10:02:36 UTC
I've done two fixes:
#1 - http://hg.netbeans.org/jet-main/rev/d3689ac59351
#2 - http://hg.netbeans.org/jet-main/rev/230f569a00e8

The main fix is #2, but #1 makes it easier to position a mouse pointer over a tooltip, which somebody complained about here too. IMO both should be applied to 6.9.1 (in the order as they're listed here).

It would be great if some of the reporters could verify that the way how tooltips are placed on the screen works fine. I hope the change is not going to cause some unwanted side effect or regression. Thanks
Comment 15 Quality Engineering 2010-06-25 03:17:01 UTC
Integrated into 'main-golden', will be available in build *201006250001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/230f569a00e8
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #180652: tooltips placement improvements; all text tooltips support lines wrapping
Comment 16 rbalada 2010-06-25 06:16:27 UTC
Last chance for inclusion in release691.

Please verify within 4 hours from now, since I have got limited time to transplant remaining bugfixes into release691 repository. June 25, 1 PM Prague time is my deadline. After that time, please do also the transplant/porting work if you want to include it.

Thank you for understanding,
-R
Comment 17 Vitezslav Stejskal 2010-06-25 08:09:39 UTC
(In reply to comment #16)
> After that time, please do also the transplant/porting
> work if you want to include it.

No problem, I can transplant the changesets once the fix is verified.
Comment 18 _ gtzabari 2010-06-26 04:20:52 UTC
I just reproduced the problem in 201006250001. I can confirm that it's easier to reach the [+] icon when it's far from the mouse but the main problem of the text not wrapping still exists.
Comment 19 Vitezslav Stejskal 2010-06-26 19:58:52 UTC
Could you please attach a screenshot here? Thanks
Comment 20 _ gtzabari 2010-06-26 20:39:48 UTC
Created attachment 100437 [details]
Screenshot of 201006250001
Comment 21 Vitezslav Stejskal 2010-06-28 06:23:17 UTC
(In reply to comment #20)
> Created an attachment (id=100437) [details]
> Screenshot of 201006250001

Ah, I see, that's a debugger tooltip, which is a whole new story, because debugger tooltips use their own components in order to provide the "+" sign feature. Anyway, the other tooltips (eg. errors, warnings, etc) should now be working fine. Are they?
Comment 22 Andrei Chistiakov 2010-06-28 11:08:46 UTC
Yes, they are.

Verified with trunk build  201006280001
Comment 23 Vitezslav Stejskal 2010-06-28 11:27:16 UTC
Ok, I'm marking this as VERIFIED and will file a new issue for the debugger tooltips. Thanks Andrei!
Comment 24 Vitezslav Stejskal 2010-06-28 11:32:47 UTC
(In reply to comment #23)
> Ok, I'm marking this as VERIFIED and will file a new issue for the debugger
> tooltips. Thanks Andrei!

There it is - issue #188149.
Comment 25 rbalada 2010-06-28 18:31:26 UTC
(In reply to comment #14)
> I've done two fixes:
> #1 - http://hg.netbeans.org/jet-main/rev/d3689ac59351
> #2 - http://hg.netbeans.org/jet-main/rev/230f569a00e8

main #d3689ac59351 transplanted to release691 #f51fccef2601
main #230f569a00e8 ported to release691 #7faa6b50cb47
Comment 26 Martin Fousek 2010-07-07 14:25:35 UTC
Verified in NetBeans IDE 6.9.1 Dev (Build 201007062301).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo