Bug 180554 - Invoking Run Main Project took 6453 ms.
Invoking Run Main Project took 6453 ms.
Status: RESOLVED DUPLICATE of bug 179178
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: David Konecny
issues@javaee
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 180555 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-10 08:11 UTC by Exceptions Reporter
Modified: 2010-03-29 23:28 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-02-10 08:11 UTC, Exceptions Reporter
Details
nps snapshot (256.00 KB, application/nps)
2010-03-07 06:52 UTC, y_widyatama
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-02-10 08:11:31 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP
Maximum slowness yet reported was 6453 ms, average is 6453
Comment 1 Exceptions Reporter 2010-02-10 08:11:38 UTC
Created attachment 94043 [details]
nps snapshot
Comment 2 y_widyatama 2010-03-07 06:52:59 UTC
Created attachment 94826 [details]
nps snapshot

I right clicked on a Maven Project, created from lift framework 2.0M2 archetype. Canceled maven download from the previous run of Netbeans.
Comment 3 David Konecny 2010-03-29 23:10:04 UTC
*** Bug 180555 has been marked as a duplicate of this bug. ***
Comment 4 David Konecny 2010-03-29 23:28:43 UTC
All these performance problems were resolved by fix of issue 179178. The reason for this problem was that WebActionProvider.isDDServlet() would be called form action and consequently web.xml would be parsed and version of web.xml would be 2.3 or older for which we removed DTDs and so parser would try to download DTDs from internet which would take in some cases considerable amount of time.

*** This bug has been marked as a duplicate of bug 179178 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo