Bug 180550 - AWT thread blocked for 3122 ms.
AWT thread blocked for 3122 ms.
Status: RESOLVED INVALID
Product: javafx
Classification: Unclassified
Component: Unsupported
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Adam Sotona
issues@javafx
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-10 07:19 UTC by Exceptions Reporter
Modified: 2011-10-19 12:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-02-10 07:19 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-02-10 07:19:02 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows Vista

User Comments:
GUEST: rodando fx



Maximum slowness yet reported was 3122 ms, average is 3122
Comment 1 Exceptions Reporter 2010-02-10 07:19:12 UTC
Created attachment 94042 [details]
nps snapshot
Comment 2 Adam Sotona 2010-02-10 07:39:00 UTC
From the snapshot it was the first execution of the JavaFX application after start and the execution was blocked for 1130ms by org.openide.filesystems.URLMapper just to obtain URL.

But URLMapper is not the reason, I see there Lucene Merge Thread consuming 2930ms CPU time and many other threads waiting exactly the same amount of time on locks.

I don't know who owns the Lucene module so please re-assign to the right person, thanks.
Comment 3 Tomas Zezula 2010-02-10 07:52:51 UTC
The issues is about blocking AWT event queue (slowness detector issue), other threads are not relevant.
Comment 4 Tomas Zezula 2010-02-10 07:54:02 UTC
Anyway feel free to decrease the priority, I personally think that the issue is not important at all.
Comment 5 Adam Sotona 2010-02-10 08:21:32 UTC
OK,
full snapshot time is 2930ms and during the whole time was one CPU core saturated with Lucene Merge Thread.

JavaFX Action Provider was blocking AWT Thread for 2930ms (1515ms pure CPU time).
- 1110ms (respectively 906ms) of that time spent by initializing of org.apache.tools.ant.module.api.AntTargetExecutor
- 1130ms waiting on blocked org.openide.URLMapper

Proposed fix is to detach the JavaFX Action Provider actions from AWT thread.
Comment 6 Anton Chechel 2011-05-19 12:40:33 UTC
Java FX v1 including Java FX Script is no longer supported.
Comment 7 David Strupl 2011-10-19 12:06:41 UTC
Cleaning bugzilla categories ....


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo