Bug 180375 - IDE hangs using 100% of CPU at random
IDE hangs using 100% of CPU at random
Status: RESOLVED DUPLICATE of bug 178133
Product: php
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: rmatous
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-06 13:27 UTC by caesar2k
Modified: 2010-02-07 05:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description caesar2k 2010-02-06 13:27:00 UTC
Lately it's being unbearable to use Netbeans on my PHP project.
I'm using Kohana framework and it hangs randomly when start typing an "if" for example, or a class. For example, when typing $v-> (that is a Validation_Core class), appears "Please wait..." then it hangs, using 100% of CPU and then rising the memory usage up to 600MB!
I have no idea when this started, but its definitely annoying, as I need to restart the IDE constantly. And I have no means to get a thread dump, because everything stops responding, until I kill it using task manager. It will end up corrupting my project files, and I will get MAD.
Comment 1 Tomas Mysik 2010-02-07 05:15:17 UTC
Likely duplicate of bug #178133. Please, read that issue and provide requested information if possible.

Thanks.

*** This bug has been marked as a duplicate of bug 178133 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo