Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 18036 - /** as abbreviation for full javadoc comment
/** as abbreviation for full javadoc comment
Status: RESOLVED FIXED
Product: usersguide
Classification: Unclassified
Component: Editor
3.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 35666 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-23 13:24 UTC by _ tboudreau
Modified: 2007-11-05 13:39 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2001-11-23 13:24:32 UTC
I'd like to see /** be an abbreviation for something like:

/**

*

*/



But what would be really nice is if the code that expands this abbreviation could also generate a correctly formatted JavaDoc comment (i.e. figure out what method I'm adding JavaDoc for and generate the correct javadoc comment for the arguments passed to the method).
Comment 1 Jan Chalupa 2001-11-27 12:27:10 UTC
Target milestone -> 3.3.1.
Comment 2 Marek Grummich 2002-07-22 10:05:39 UTC
Set target milestone to TBD
Comment 3 Marek Grummich 2002-07-22 10:09:55 UTC
Set target milestone to TBD
Comment 4 aaime 2002-11-09 17:28:52 UTC
If you need a multiline comment, see issue 23571, if you  
need to create a javadoc comment why don't you use the 
"tools -> correct javadoc", seems to be doing what you're 
asking for... if that's the case, maybe you can close the 
issue, if it's the former mark as a duplicate of 23571... if not, 
well, maybe I misunderstood your problem :-) 
Comment 5 Roman Strobl 2005-01-21 13:12:40 UTC
Changed subcomponent to documentation.
Comment 6 _ tboudreau 2005-01-24 16:10:27 UTC
Are you sure the documentation subcomponent  is correct here?  Maybe the Editor team uses 
it differently, but traditionally we've used the documentation subcomponent to indicate a bug 
in the javadoc of a module's API, not the editor's support for javadoc.
Comment 7 tomzi 2005-02-09 12:07:07 UTC
You could also automatically add @param @return .. tags. This would be
way faster than using the auto completion dialogue box each time i
create a new method and thus would definately improve usability.

I've seen that jDeveloper suppports that, I'm not certain with Eclipse...
Comment 8 Miloslav Metelka 2005-02-10 10:19:02 UTC
I think we should finally implement this for promoF.
Once implemented we should IMHO change the behavior of the Enter
pressed at the end of the line inside Javadoc comment - currently it
inserts '<indent>*' i.e.

    /**
     * typed text
     *|

 as the user may want to type '/' to end the comment. After
implementation of this enhancement we should start adding an extra
space after '*' i.e.

    /**
     * typed text
     * |
     */

as the closing '*/' was inserted automatically.
Comment 9 Roman Strobl 2005-02-10 10:24:49 UTC
Mila, I completely agree, this is how other IDEs have it, let's do it
this way.
Comment 10 Jan Pokorsky 2006-04-12 10:52:38 UTC
*** Issue 35666 has been marked as a duplicate of this issue. ***
Comment 11 Jiri Prox 2007-10-30 10:47:03 UTC
this is implemented in 6.0


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo