Bug 180302 - No documentaion for the issue tracker api
No documentaion for the issue tracker api
Status: RESOLVED DUPLICATE of bug 162279
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Tomas Stupka
issues@connecteddeveloper
: API
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 16:38 UTC by adamgmetzler
Modified: 2010-02-05 02:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description adamgmetzler 2010-02-04 16:38:30 UTC
There does not seem to be any documentation for the issue tracker api or any information if the api is exported for others to use to add new connectors. If it is not a public api it should be so others can add connector implementations now that kenai is dead, this is greatly needed so people don't lose all the kenai functionality. If it is public it needs documentation in the platform java docs and maybe an example implementation on the community docs page.
Comment 1 Tomas Stupka 2010-02-05 02:28:32 UTC
the public bugtracking spi is already tracked by issue #162279.

> If it is not a public api it should be so others can add connector 
> implementations now that kenai is dead, this is greatly needed so people don't > lose all the kenai functionality
the kenai functionality covered by the bugtracking modules is the bugzilla and jira trackers which already are implemented in netbeans and available in build and UC. What else do you have in mind?

*** This bug has been marked as a duplicate of bug 162279 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo