Bug 179979 - IllegalStateException: Method can be called only on model waiting for bg thread to populate it.
IllegalStateException: Method can be called only on model waiting for bg thre...
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
EXCEPTIONS_REPORT
: RANDOM, THREAD
: 183563 (view as bug list)
Depends on:
Blocks: 173422
  Show dependency treegraph
 
Reported: 2010-01-29 00:05 UTC by _ tboudreau
Modified: 2010-04-30 04:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.25 KB, text/plain)
2010-01-29 00:06 UTC, _ tboudreau
Details
stacktrace (3.25 KB, text/plain)
2010-04-06 18:44 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2010-01-29 00:05:58 UTC
Build: NetBeans IDE Dev (Build null)
VM: Java HotSpot(TM) Server VM, 17.0-b01, Java(TM) SE Runtime Environment, 1.7.0-ea-b72
OS: Windows XP

User Comments:
tboudreau: Changing platform of a standalone module project to use a build in $NBSRC/nbbuild/netbeans




Stacktrace: 
java.lang.IllegalStateException: Method can be called only on model waiting for bg thread to populate it.
   at org.netbeans.modules.apisupport.project.ui.customizer.CustomizerComponentFactory$DependencyListModel.setDependencies(CustomizerComponentFactory.java:230)
   at org.netbeans.modules.apisupport.project.ui.customizer.SingleModuleProperties$2$1.run(SingleModuleProperties.java:523)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:235)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:616)
   at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:127)
   at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:286)
Comment 1 _ tboudreau 2010-01-29 00:06:02 UTC
Created attachment 93643 [details]
stacktrace
Comment 2 Jesse Glick 2010-04-06 18:44:16 UTC
Created attachment 96806 [details]
stacktrace

Changed platform of a standalone module.
Comment 3 Jesse Glick 2010-04-06 22:31:49 UTC
*** Bug 183563 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Glick 2010-04-27 23:08:34 UTC
No idea how to reproduce, but probably harmless.
Comment 5 Jesse Glick 2010-04-27 23:10:53 UTC
core-main #f9810ebcd54d
Comment 6 Quality Engineering 2010-04-30 04:59:32 UTC
Integrated into 'main-golden', will be available in build *201004300200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo