Bug 179961 - [J2EE] No able to start profiling JBoss 5.1.0
[J2EE] No able to start profiling JBoss 5.1.0
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Ide
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Denis Anisimov
issues@profiler
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-28 07:22 UTC by Denis Anisimov
Modified: 2013-10-16 07:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Anisimov 2010-01-28 07:22:37 UTC
Create Web Project .
Set JBoss as J2EE server .
Call "Profile" popup menu item for project .

As result there is no information about server start up.
Output contains :
>Calling _path_to_jboss-5.1.0.GA\bin\run.conf.bat
>and was unexpected at this time.

Profiling tab is not opened and it is impossible to see profiling information.
Comment 1 Denis Anisimov 2010-01-28 07:38:40 UTC
The problem is inside run.bat of JBoss bin directory.


I have commented out checks for RUN_CONF and realized that 
this error still presents.

For some reasons this lines generates mentioned output :
>if "x%JAVA_OPTS%" == "x" (
>  set "JAVA_OPTS=-Dprogram.name=%PROGNAME%"
>) else (
>  set "JAVA_OPTS=-Dprogram.name=%PROGNAME% %JAVA_OPTS%"
>)

I don't now why this code doesn't work .


In my case JAVA_OPTS is 
-Xms128m -Xmx512m  -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath="F:\Documents and Settings\den\My Documents\NetBeansProjects\WebApplicationJBoss\nbproject\private\profiler"  -agentpath:C:\dev\profiler-main\nbbuild\netbeans\profiler3\lib\deployed\jdk16\windows\profilerinterface.dll=C:\dev\profiler-main\nbbuild\netbeans\profiler3\lib,5140 -Dnbprofiler.agentid=1171412876.

Probably the matter is quotes "" inside env variable JAVA_OPTS ( probably other
variables which are set for run.bat process ).
Comment 2 Denis Anisimov 2010-01-30 08:21:54 UTC
This is result of spaces in path.
If spaces are present then path are surrounded by quotes.
As result bat file fails in lines like
>if "x%JAVA_OPTS%" == x .....

See https://jira.jboss.org/jira/browse/JBAS-6725.
Comment 3 Denis Anisimov 2010-02-26 04:22:34 UTC
changeset:   159427:a7df377e01dd
user:        Denis Anisimov <ads@netbeans.org>
date:        Fri Feb 26 14:12:36 2010 +0300
summary:     Fix for BZ#179961 -  [J2EE] No able to start profiling JBoss 5.1.0
Comment 4 Quality Engineering 2010-03-04 22:11:43 UTC
Integrated into 'main-golden', will be available in build *201003050200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a7df377e01dd
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#179961 -  [J2EE] No able to start profiling JBoss 5.1.0


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo