Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179904 - convert to composite component generates incorrect URL
convert to composite component generates incorrect URL
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF Editor
6.x
PC Linux
: P1 (vote)
: TBD
Assigned To: pgebauer
issues@javaee
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-27 04:39 UTC by Jindrich Sedek
Modified: 2010-01-28 01:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2010-01-27 04:39:38 UTC
Create new Web Application with JSF framework
select a piece of code and invoce Convert To Composite Component action
press Finish
open newly generated file out.xhtml -> 
incorrect namespace is generated and most of the code is thus marked with error
------------
      xmlns:cc="http://java.sun.com/jsf/cc">
------------


The problem is reproducible only in 6.8 and not in trunk.
Comment 1 Marek Fukala 2010-01-27 06:44:14 UTC
following changeset hasn't been transplanted to relase68_fixes branch:

http://hg.netbeans.org/web-main/rev/30a3ab80cf02

Please integrate into the branch if still feasible.
Comment 2 pgebauer 2010-01-27 07:18:16 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/7127552b1fc3
Comment 3 Michal Mocnak 2010-01-28 01:15:46 UTC
Verified in 68fixes branch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo