Bug 179897 - Focus issue in undocked Navigator
Focus issue in undocked Navigator
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Navigation
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-27 03:13 UTC by kirillkh
Modified: 2010-06-03 21:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kirillkh 2010-01-27 03:13:34 UTC
Product Version: NetBeans IDE 6.8 (Build 200912041610)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01
System: Linux version 2.6.31-17-generic running on amd64; UTF-8; en_US (nb)
----------------------------

The following issue occurs, when the Navigator window is undocked from the main window. When editing a file in the main window and then pressing the shortcut to switch to Navigator (Ctrl-7 in NB5.5 bindings), a wrong component inside the Navigator window gets focus, so in order to make arrow buttons (or search-by-typing) to work, one has to press TAB twice. This works fine if Navigator is docked into the main window.

I have dual-monitor setup, but this doesn't seem to matter (at least the issue manifests itself even when I place all windows onto the main monitor).
Comment 1 kirillkh 2010-01-27 03:17:36 UTC
The issue is not present in other windows (Projects or Files), when they are undocked (e.g. arrow buttons work immediately without pressing TAB).
Comment 2 Tomas Zezula 2010-02-09 06:23:45 UTC
Sorry Dafe, it's mine.
Comment 3 Tomas Zezula 2010-02-09 06:48:20 UTC
Fixed in jet-main: 88cb19070308
Comment 4 Quality Engineering 2010-02-10 02:18:55 UTC
Integrated into 'main-golden', will be available in build *201002100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/88cb19070308
User: Tomas Zezula <tzezula@netbeans.org>
Log: #179897:Focus issue in undocked Navigator
Comment 5 kirillkh 2010-06-03 21:09:47 UTC
Verified in 6.9 RC1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo